- NetBSD Manual Pages
ISA(4) NetBSD Kernel Interfaces Manual ISA(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
isa -- introduction to machine-independent ISA bus support and drivers
Attachments are machine-dependent and depend on the bus topology and ISA
bus interface of your system. See intro(4) for your system for details.
NetBSD includes a machine-independent ISA bus subsystem and several
machine-independent ISA device drivers.
Your system may support additional ISA devices. Drivers for ISA devices
not listed here are machine-dependent. Consult your system's intro(4)
for additional information.
NetBSD includes machine-independent ISA drivers, sorted by device type
and driver name:
adv(4) Advansys SCSI interfaces.
aha(4) Adaptec AHA-154x family (154xA, 154xB, 154xC, and
154xCF) and the BusLogic BT54x SCSI interfaces.
ahc(4) Adaptec 29xx, 39xx, and other AIC-7xxx-based SCSI inter-
aic(4) Adaptec AIC-6260 and Adaptec AIC-6360 based SCSI inter-
faces, including the Adaptec 152x, SoundBlaster SCSI
interfaces, and a variety of compatibles.
bha(4) BusLogic BT-445 SCSI interfaces.
dpt(4) DPT SmartCache/SmartRAID III and IV SCSI interfaces.
esp(4) NCR 53C9x, Emulex ESP406, and Qlogic FAS408 SCSI inter-
sea(4) Seagate/Future Domain SCSI cards. ST01/02, Future
Domain TMC-885, and Future Domain TMC-950.
uha(4) Ultrastor 14f SCSI interfaces.
wds(4) WD-7000 family of bus-mastering SCSI interfaces.
Disk and tape controllers
mcd(4) Mitsumi CD-ROM drives.
wdc(4) Standard Western Digital type hard drive controllers:
MFM, RLL, ESDI, and IDE/ATAPI.
wt(4) Wangtek and compatible QIC-02 and QIC-36 tape drives.
Serial and parallel interfaces
ast(4) Multi-port serial communications card first made by AST.
boca(4) Boca BB100 and BB2016 multiplexing serial communica-
com(4) NS8250-, NS16450-, and NS16550-based serial ports.
cy(4) Cyclades Cyclom-4Y, -8Y, and -16Y asynchronous serial
ioat(4) BOCA Research IOAT66 serial interfaces.
lpt(4) Standard ISA parallel port interface.
rtfps(4) IBM RT four-port serial interfaces.
tcom(4) Byte Runner Technologies TC-400 and TC-800 series serial
ai(4) AT&T StarLan Ethernet interfaces.
ate(4) Allied Telesis AT1700 series and RE2000 series Ethernet
cs(4) Cirrus Logic Crystal CS8900 Ethernet interfaces.
ec(4) 3Com EtherLink II (3c503) Ethernet interfaces.
ef(4) 3Com EtherLink II (3c507) Ethernet interfaces.
eg(4) 3Com EtherLink Plus (3c505) Ethernet interfaces.
el(4) 3Com EtherLink (3c501) Ethernet interfaces.
ep(4) 3Com EtherLink III (3c509) Ethernet interfaces.
fmv(4) Fujitsu FMV-181 and FMV-182 interfaces.
ix(4) Intel EtherExpress/16 Ethernet interfaces.
iy(4) Intel i82595-based Ethernet interfaces, including the
lc(4) DEC EtherWORKS III Ethernet interfaces (DE203, DE204,
le(4) Ethernet interfaces based on the AMD LANCE chip, includ-
ing BICC Isolan, Novell NE2100, Digital DEPCA, and
ne(4) Novel NE2000 and compatible Ethernet interfaces.
ntwoc(4) SDL Communications Riscom/N2 synchronous serial inter-
sm(4) SMC91C9x-based Ethernet interfaces.
we(4) Western Digital/SMC 80x3, SMC Elite Ultra, and SMC
EtherEZ Ethernet interfaces.
Sound cards and MIDI interfaces
aria(4) Sierra's Aria based sound cards.
cms(4) Creative Music System.
ess(4) ESS Technology AudioDrive 1788-, 1888-, 1887-, and
888-based sound cards.
gus(4) Gravis Ultrasound sound cards.
mpu(4) Roland MPU401 (and compatible) MIDI UARTs.
opl(4) Yamaha OPL2 and OPL3 FM MIDI synthesizers.
pas(4) ProAudio Spectrum sound cards.
sb(4) SoundBlaster, SoundBlaster 16, and SoundBlaster Pro
wss(4) Windows Sound System-compatible sound cards based on the
AD1848 and compatible chips.
az(4) Aztech/PackardBell radio card.
lm(4) National Semiconductor LM78, LM79 and compatible hard-
nct(4) Nuvoton NCT5104D SuperIO.
PC display adapters.
pcic(4) PCI PCMCIA controllers, including the Cirrus Logic
pckbc(4) PC keyboard controllers.
pcppi(4) PC control and timer ports.
pms(4) PS/2 auxiliary port mice (including wheel mice).
rt(4) AIMS Lab Radiotrack FM radio.
rtii(4) AIMS Lab Radiotrack II FM radio.
sf2r(4) SoundForte RadioLink SF16-FMR2 FM radio.
tcic(4) Databook DB86082, DB86084, DB86184, and DB86072 PCMCIA
vga(4) VGA graphics boards.
wbsio(4) Winbond LPC Super I/O.
Note that some ISA devices also have newer ISA Plug-and-Play variants.
These are listed in isapnp(4).
Stray interrupt on IRQ 7 It means the interrupt controller reported an
unmasked interrupt on IRQ 7, but no driver attached to that IRQ `claimed'
There are two reasons this can happen:
· In anything other than i386, it would almost always mean that there
is a driver attached to the IRQ, but it is the wrong driver.
· On i386, there is the more obscure issue of `default IRQ7's. That
is, when a device asserts an IRQ, but the IRQ is deasserted after the
PIC latches the interrupt and before the CPU acknowledges it, the PIC
just flat out lies about which IRQ it was. It is usually due to a
suboptimally coded driver.
intro(4), isapnp(4), isa(9)
The machine-independent ISA subsystem appeared in NetBSD 1.2.
NetBSD 10.99 October 25, 2019 NetBSD 10.99