- NetBSD Manual Pages
EP(4) NetBSD Kernel Interfaces Manual EP(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ep -- driver for 3Com EtherLink III Ethernet interfaces
ep0 at isa? port ? irq ?
ep* at isapnp?
ep* at eisa? slot ?
ep* at mca? slot ?
ep* at pci? dev ? function ?
ep* at pcmcia? function ?
The ep device driver supports the 3Com EtherLink III family of Ethernet
The 3c515 is an ISA 10/100 card with DMA capability. The chipset is sim-
ilar to that of the 3c905, with some changes to make it work with the
more limited ISA bus address space. This card is supported, although DMA
is not used.
The EISA and PCI 3c59x devices use an older DMA engine which is not capa-
ble of multi-segment DMA. DMA on these devices is not used.
The 3c529 is a MCA device, and doesn't support DMA.
The PCI 3c90x devices have multi-segment DMA capability, which is not
supported by the ep driver. To use the DMA capabilities of these cards,
the ex(4) driver must be used.
The PCI 3c90xB devices are not supported by the ep driver, as they do not
include support for programmed I/O. These devices are supported by the
The 3c575 is a CardBus device, and is supported by ex(4) driver.
There are 3 main chipset classes supported by the ep driver. Each has
their own media selection capabilities.
The first class is the ``3c509'' class. This includes the 3c509, 3c509B,
3c529, 3c579, 3c562, and 3c589. These devices can support 10BASE-T,
10BASE2, and 10BASE5. Available media will be displayed when the device
is found by the kernel.
The second class is the ``Vortex'' class. This includes the 3c592,
3c579, 3c590, and 3c595. This class also includes the 3c900-TPO and
3c900-COMBO; they use the ``Boomerang'' chipset, but use Vortex-style
media selection. These devices have many different media types varying
by model. Some models have an external MII connector for connecting an
external PHY. This is supported by means of the ``manual'' media type.
Available media will be displayed when the device is found by the kernel.
The third class is the ``Boomerang'' class. This includes the 3c515,
3c905, and 3c574. These devices support media selection via MII. The
3c515 and 3c905 have an nsphy(4), and the 3c574 has a tqphy(4), for this
purpose. See ifmedia(4) and mii(4) for more information.
Supported cards include:
3c509 ISA 10Mbps card, in BNC and multiport variants
3c509B ISA Plug-and-Play 10Mbps card, in BNC and multiport vari-
3c515 ISA Plug-and-Play 10/100 card with UTP
3c529 MCA 10Mbps card, in UTP+AUI and BNC+AUI variants
3c556B PCMCIA 56K modem-10/100Mbps Ethernet combo card with dongle
3c562 PCMCIA modem-10Mbps Ethernet combo card with dongle
3c574 PCMCIA 10/100Mbps card with dongle
3c579 EISA 10Mbps card, in UTP, BNC, and multiport variants
3c589 PCMCIA 10Mbps card with dongle
3c590 PCI 10Mbps multiport card with DMA capability
3c592 EISA 10Mbps card with DMA capability
3c595 PCI 10/100Mbps with different media options and DMA capa-
3c597 EISA 10/100Mbps card with DMA capability
3c900 PCI 10Mbps card in 10BASE-T and multiport variants with DMA
3c905 PCI 10/100Mbps card in 10BASE-T, multiport, and fast vari-
ants with DMA capability
EtherLink III cards have no jumpers to set the address. 3Com supplies
software to set the address of the card in software. To find the card on
the ISA bus, the kernel performs a complex scan operation at IO address
0x100. Beware! Avoid placing other cards at that address!
The 3Com configuration utilities can `autosense' the active media and
save it as default. The saved default medium is the medium that was
active at the time the configuration utility was run. The ep driver does
not yet re-autosense the active media at boot time. If the EEPROM
autosense bit is set, the driver simply uses the media type sensed and
saved when the configuration utility was run.
ep0: reset (status: %x) The driver has encountered a FIFO underrun or
overrun. The driver will reset the card and the packet will be lost.
This is not fatal.
ep0: eeprom failed to come ready The EEPROM failed to come ready. This
probably means the card is wedged.
ep0: 3c509 in test mode. Erase pencil mark! This means that someone has
scribbled with pencil in the test area on the card. Erase the pencil
mark and reboot. (This is not a joke.)
eisa(4), ex(4), ifmedia(4), intro(4), isa(4), isapnp(4), mca(4), mii(4),
nsphy(4), pci(4), pcmcia(4), tqphy(4), ifconfig(8)
NetBSD 9.99 October 30, 2007 NetBSD 9.99