- NetBSD Manual Pages
IOAT(4) NetBSD Kernel Interfaces Manual IOAT(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ioat -- multiplexing serial communications interface
For 6-port BOCA IOAT66 board:
ioat0 at isa? port 0x220 irq 5
com2 at ioat? slave ?
com3 at ioat? slave ?
com4 at ioat? slave ?
com5 at ioat? slave ?
com6 at ioat? slave ?
com7 at ioat? slave ?
The ioat driver provides support for BOCA Research IOAT66 boards that
multiplex together up to six EIA RS-232C (CCITT V.28) communications
Each ioat device is the master device for up to six com devices. The
kernel configuration specifies these com devices as slave devices of the
ioat device, as shown in the synopsis. The slave ID given for each com
device determines which bit in the interrupt multiplexing register is
tested to find interrupts for that device. The port specification for
the ioat device is used to compute the base addresses for the com subde-
vices. The port for the interrupt multiplexing register is not pro-
The ioat driver was adapted from the boca driver by Michael Richardson.
NetBSD 9.99 January 24, 2000 NetBSD 9.99