- NetBSD Manual Pages
INTRO(4) NetBSD/i386 Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to i386 special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
This section describes the hardware supported on the i386 (PC-clone)
platform. Software support for these devices comes in two forms. A
hardware device may be supported with a character or block device driver,
or it may be used within the networking subsystem and have a network
interface driver. Block and character devices are accessed through files
in the file system of a special type; see mknod(8). Network interfaces
are indirectly accessed through the interprocess communication facilities
provided by the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system must be rebooted.
The autoconfiguration system is described in x86/autoconf(4). A list of
the supported devices is given below.
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
Standard builtin devices:
com(4) NS8250-, NS16450-, and NS16550-based asynchronous
serial communications device interface
x86/lpt(4) Parallel port device interface
x86/fdc(4) Standard NEC 765 floppy disk controller.
mca(4) MCA I/O bus.
x86/mem(4) Main memory interface
pci(4) PCI I/O bus.
eisa(4) EISA I/O bus, either as main bus or via PCI-EISA
isa(4) ISA bus and ISA devices, either as main bus or via PCI-
isa(4) isa I/O bus.
isapnp(4) ``bus'' for ISA devices with PnP support.
speaker(4) console speaker device interface
PCMCIA devices are supported through the pcmcia(4) bus and associated
Cardbus devices are supported through the cardbus(4) bus and associated
USB devices are supported through the usb(4) bus and associated device
Console devices using ISA, EISA, or PCI video adaptors and standard AT or
PS/2 keyboards are supported by the machine independent wscons(4) console
config(1), netintro(4), x86/autoconf(4)
The i386 intro appeared in NetBSD 1.0.
NetBSD 10.99 February 26, 2021 NetBSD 10.99