- NetBSD Manual Pages
AXEN(4) NetBSD Kernel Interfaces Manual AXEN(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
axen -- ASIX Electronics AX88178a/AX88179 10/100/Gigabit USB Ethernet
axen* at uhub? port ?
rgephy* at mii?
The axen driver provides support for USB Ethernet adapters based on the
ASIX Electronics AX88178a USB 2.0 and AX88179 USB 3.0 chipsets including
Shanghai Donya DN-84327
The axen driver supports the following media types:
autoselect Enable autoselection of the media type and options (this is
the default). The user can manually override the autose-
lected mode by adding media options to the appropriate
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseT Set 1000Mbps (Gigabit Ethernet) operation.
For more information on configuring this device, see ifconfig(8).
See usbnet(4) for diagnostics.
arp(4), mii(4), netintro(4), rgephy(4), usb(4), usbnet(4),
The axen device driver first appeared in OpenBSD 5.4 and in NetBSD 7.0.
The axen driver was written by Yojiro UO <firstname.lastname@example.org> for OpenBSD and
ported to NetBSD by NONAKA Kimihiro <nonaka@NetBSD.org>.
NetBSD 10.99 August 24, 2019 NetBSD 10.99