- NetBSD Manual Pages
TC(4) NetBSD Kernel Interfaces Manual TC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
tc -- TURBOchannel expansion bus driver
tc* at tcasic?
tc* at mainbus0
tc0 at vsbus0
The tc driver provides machine-independent support for the DEC TURBOchan-
nel expansion bus found on all DEC 5000-series machines with MIPS, DEC
3000-series with Alpha processors and VAXstation 4000 machines with the
optional TURBOchannel adaptor.
Your system may support additional TURBOchannel devices. Drivers for
TURBOchannel devices not listed here are machine-dependent. Consult your
system's intro(4) for additional information.
NetBSD includes machine-independent TURBOchannel drivers, sorted by
device type and driver name:
tcds(4) PMAZ-DS, PMAZ-FS, PMAZB-AA and PMAZC-AA dual-channel
le(4) LANCE Ethernet interface
cfb(4) PMAG-B CX colour unaccelerated 2-D framebuffer
mfb(4) PMAG-A MX monochrome framebuffer
px(4) PMAG-C PX accelerated graphics boards
pxg(4) PMAG-D, PMAG-E and PMAG-F PXG accelerated graphics
sfb(4) PMAGB-BA HX colour unaccelerated 2-D framebuffer
tfb(4) PMAG-J TX 24-bit colour unaccelerated 2-D framebuffer
ioasic(4) baseboard IO control ASIC for DEC TURBOchannel systems
tcu(4) TC-USB USB host and GPIO option
The tc driver first appeared in NetBSD 1.1.
The tc driver makes poor use of interrupt priority on the 5000/1xx series
NetBSD 9.99 February 26, 2021 NetBSD 9.99