- NetBSD Manual Pages
SYSINST(8) NetBSD System Manager's Manual SYSINST(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
sysinst -- install or upgrade a NetBSD system
sysinst [-Dp] [-C bg:fg] [-f definition_file] [-m message_catalog_dir]
sysinst is a menu-based program that may be used to install or upgrade a
NetBSD system. It is usually invoked automatically when the system is
booted from appropriate installation media.
The following options are available:
-C bg:fg Use the ansi colors (see <curses.h>) bg as
background (default: 4 for blue) and fg as
foreground/text color (default: 7 for white).
-D Switch on debugging.
-f definition_file Use definition_file as a file for definitions
other than the defaults. See the DEFINITION
FILE section for its format.
-m message_catalog_dir Search for available language files in
message_catalog_dir. If this argument is miss-
ing and there are sysinstmsgs.* files in the
current directory, those are used. If no such
files are found, a compiled in default catalog
directory is used.
-p Start the extended partition editor instead of
the installer. This option is not available on
some versions compiled for space limited
A definition file can be used with sysinst to control several aspects of
the installation or upgrade process. Options can be stored within the
option = value
pairs. Options include the following, shown with their defaults as well
as a description (``REL'' and ``MACH'' are the release and architecture
respectively, as determined by the image sysinst is used on):
option name default value description
machine MACH Machine architecture
xfer dir /usr/INSTALL Transfer dir
ext dir Extract dir (will usually be
set later on)
ftp host ftp.NetBSD.org FTP host for fetching files
ftp dir pub/NetBSD/NetBSD-REL FTP directory for fetching
ftp prefix /MACH/binary/sets Directory to look for sets,
used for all methods of
fetching (i.e., not just
ftp user ftp FTP user for connecting
ftp pass - FTP password
ftp proxy - FTP proxy
nfs host - NFS host for fetching via
nfs dir /bsd/release NFS directory for fetching
cd dev cd0a Name of CD device for
fd dev /dev/fd0a Name of floppy device for
local dev - Other device to be mounted
for fetching files
local fs ffs File system type for local
local dir release Directory to look for in the
mounted local file system
targetroot mount /targetroot Directory to mount target
root dir to
dist postfix .tgz Suffix of set files to be
diskname mydisk disktab(5) diskname to use
for target disk
release(7), afterboot(8), boot(8), diskless(8)
<machine>/INSTALL.* files on CD-ROM installation media
.../NetBSD-<rel>/<machine>/INSTALL.* files in NetBSD releases or snap-
The default message catalog files are installed in
A sysinst command appeared in NetBSD 1.3.
NetBSD 9.99 January 28, 2022 NetBSD 9.99