- NetBSD Manual Pages
ITE(4) NetBSD/amiga Kernel Interfaces Manual ITE(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ite -- Amiga Internal Terminal Emulator
ite0 at grf0
ite1 at grf1
ite2 at grf2
ite3 at grf3
ite4 at grf4
ite5 at grf5
ite6 at grf6
ite7 at grf7
TTY special files of the form ``ttye?'' are interfaces to the Amiga ITE
for bit-mapped displays. An ite is the main system console on most Amiga
workstations and is the mechanism through which a user communicates with
the machine. If more than one of the supported displays exists on a sys-
tem, any or all can be used as ite s with the limitation that only one
will have a keyboard (since only one keyboard is supported) and only one
of each type can be used.
ite devices use the HP-UX `300h' terminfo(5) entry. However, as cur-
rently implemented, the ite does not support the full range of HP-UX
capabilities for this device. Missing are multiple colors, blinking,
softkeys, programmable tabs, scrolling memory and keyboard arrow keys.
The keyboard will use the left and right Amiga keys as meta keys, in that
it will set the eighth bit of the character code. ite devices also do a
good job at emulating the `vt100' terminfo(5) entry.
Upon booting, the kernel will first look for an ite device to use as the
system console (/dev/console). If a display exists at any hardware
address, it will be the console. The kernel looks for them in decreasing
order (that is, choosing the highest-numbered one).
On most systems, a display is used both as an ite (/dev/ttye? aka
/dev/console) and as a graphics device (/dev/grf?). In this environment,
there is some interaction between the two uses that should be noted. For
example, opening /dev/grf0 will deactivate the ite that is, write over
whatever may be on the ite display. When the graphics application is
finished and /dev/grf0 closed, the ite will be reinitialized with the
frame buffer cleared and the old colormap installed.
The Amiga ite first appeared in NetBSD 1.0
NetBSD 10.99 February 17, 2017 NetBSD 10.99