- NetBSD Manual Pages
DHCPCD.CONF(5) System Manager's Manual DHCPCD.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dhcpcd.conf -- dhcpcd configuration file
Although dhcpcd can do everything from the command line, there are cases
where it's just easier to do it once in a configuration file. Most of
the options found in dhcpcd(8) can be used here. The first word on the
line is the option and the rest of the line is the value. Leading and
trailing whitespace for the option and value are trimmed. You can escape
characters in the value using the \ character.
Blank lines and lines starting with # are ignored.
Here's a list of available options:
Background immediately. This is useful for startup scripts which
don't disable link messages for carrier status.
Ignores all DHCP messages which have this address as the server
ID. This may be expanded in future releases to ignore all pack-
ets matching either the IP or hardware address.
Send the clientid. If the string is of the format 01:02:03 then
it is encoded as hex. For interfaces whose hardware address is
longer than 8 bytes, or if the clientid is an empty string then
dhcpcd sends a default clientid of the hardware family and the
duid Generate an RFC 4361. compliant clientid. This requires persis-
tent storage and not all DHCP servers work with it so it's not
enabled by default. The duid generated will be held in
/etc/dhcpcd.duid and should not be copied to other hosts.
Sends specified hostname to the DHCP server so it can be regis-
tered in DNS. If hostname if a FQDN (ie, contains a .) then it
will be encoded as such.
fqdn [none | ptr | both]
none disables FQDN encoding, ptr just asks the DHCP server to
update the PTR record of the host in DNS whereas both also
updates the A record. The current hostname or the hostname spec-
ified using the hostname option must be a FQDN. dhcpcd itself
never does any DNS updates. dhcpcd encodes the FQDN hostname as
specified in RFC1035.
Subsequent options are only parsed for this interface.
Request a leasetime of seconds.
noarp Don't send any ARP requests. This also disables IPv4LL.
Don't install any default routes.
Don't run this hook script. Matches full name, or prefixed with
2 numbers optionally ending with .sh.
Don't attempt to obtain an IPv4LL address if we failed to get one
via DHCP. See RFC 3927.
nolink Don't receive link messages about carrier status. You should
only set this for buggy interface drivers.
Requests the option from the server. It can be a variable to be
used in dhcpcd-run-hooks(8) or the numerical value. You can
specify more options seperated by commas, spaces or more option
lines. quiet Supress any dhcpcd output to the console, except
Requires the option to be present in all DHCP messages, otherwise
the message is ignored. It can be a variable to be used in
dhcpcd-run-hooks(8) or the numerical value. You can specify more
options seperated by commas, spaces or more require lines.
Use script instead of the default /libexec/dhcpcd-run-hooks.
The default timeout for waiting for a DHCP response is 30 seconds
which may be too long or too short and can be changed here.
Tag the DHCP messages with the userclass. You can specify more
Add an enscapulated vendor option. code should be between 1 and
254 inclusive. Examples.
Set the vendor option 01 with an IP address.
Set the vendor option 02 with a hex code.
Set the vendor option 03 with an IP address as a string.
Change the default vendorclassid sent from dhcpcd-version. If
not set then none is sent.
Roy Marples <firstname.lastname@example.org>
Please report them to http://roy.marples.name/projects/dhcpcd
NetBSD 5.0 November 18, 2008 NetBSD 5.0