- NetBSD Manual Pages
DHCPCD.SH(8) System Manager's Manual DHCPCD.SH(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dhcpcd-run-hooks -- DHCP client configuration script
dhcpcd-run-hooks is used by dhcpcd(8) to run any system and user defined
hook scripts. System hook scripts are found in /libexec/dhcpcd-hooks and
the user defined hooks are /etc/dhcpcd.enter-hook. and
/etc/dhcpcd.exit-hook. The default install supplies hook scripts for
configuring /etc/resolv.conf and the hostname. Your distribution may
have included other hook scripts to say configure ntp or ypbind. A test
hook is also supplied that simply echos the dhcp variables to the console
from DISCOVER message.
Each time dhcpcd-run-hooks is invoked, $interface is set to the interface
that dhcpcd is run on and $reason is to the reason why dhcpcd-run-hooks
was invoked. DHCP information to be configured is held in variables
starting with the word new_ and old DHCP information to be removed is
held in variables starting with the word old_. dhcpcd can display the
full list of variables it knows how about by using the -V, --variables
Here's a list of reasons why dhcpcd-run-hooks could be invoked:
dhcpcd is starting up and any pre-initialisation should be done.
INFORM dhcpcd informed a DHCP server about it's address and obtained
other configuration details.
BOUND dhcpcd obtained a new lease from a DHCP server.
RENEW dhcpcd renewed it's lease.
REBIND dhcpcd has rebound to a new DHCP server.
REBOOT dhcpcd successfully requested a lease from a DHCP server.
EXPIRE dhcpcd's lease expired and it failed to obtain a new one.
IPV4LL dhcpcd failed to contact any DHCP servers but did obtain an
FAIL dhcpcd failed to contact any DHCP servers or use an old lease.
dhcpcd failed to contact any DHCP servers but was able to use an
TEST dhcpcd received an OFFER from a DHCP server but will not config-
ure the interface. This is primarily used to test the variables
are filled correctly for the script to process them.
When dhcpcd-run-hooks runs, it loads /etc/dhcpcd.enter-hook and any
scripts found in /libexec/dhcpcd-hooks in a lexical order and then
Roy Marples <email@example.com>
Please report them to http://roy.marples.name/projects/dhcpcd
NetBSD 5.0 August 14, 2008 NetBSD 5.0