- NetBSD Manual Pages
RELEASE(7) NetBSD Miscellaneous Information Manual RELEASE(7)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
release -- layout of NetBSD releases and snapshots
This document describes the layout of NetBSD releases and snapshots.
This layout should be consistent between FTP servers and CD-ROMs, except
possibly the path that leads to the release hierarchy.
In this document, the following special words have these definitions:
<machine> The platform for which the release was built, correspond-
ing to the hw.machine sysctl variable, e.g., i386 or
<machine_arch> The architecture for which a particular installation set
was built, corresponding to the hw.machine_arch sysctl
variable, e.g., i386 or m68k.
<rel> The release version number.
All README files are descriptions of the various files in directories
that have ``non-standard'' contents. There may also be a README file at
the top-level, describing who built the snapshot and under what circum-
stances (e.g., whether it's an official NetBSD snapshot, or not).
All MD5 files are MD5 digests for the various files in that directory, in
the format produced by the command: cksum -a MD5 <file>.
All SHA512 files are SHA512 digests for the various files in that direc-
tory, in the format produced by the command: cksum -a SHA512 <file>.
The SHA512 digest is safer, but MD5 checksums are provided so that a
wider range of operating systems can check the integrity of the release
Files that end in .tgz are gzipped tar archives. This is used in lieu of
.tar.gz because the software used to download the sets may incorrectly
auto-unpack files ending in .gz and to accommodate systems which only
support 3 character extensions to file names.
All tar archives are relative to the target's / directory, and do not
include the leading ``/''.
The root of the release hierarchy may be the root directory of a CD-ROM,
but in all other cases it should be .../NetBSD-<rel>/.
The root of the release hierarchy should contain the following files and
images/ Image files intended for use in installing NetBSD. There are
different types of images for different platforms, and some-
times multiple different image types for a single platform.
Images in this directory, unlike images in the
.../NetBSD-<rel>/<machine>/installation/ directories, contain
file systems that have an internal layout that corresponds to
a complete release for a given machine type. If built with
``iso-image-source'', then it will also contain a ``source''
directory. These images are usually bootable.
NetBSD-<rel>-<machine>.iso CD-ROM images in ISO 9660 format,
usually created with ``./build.sh
... iso-image ...'' after a
``./build.sh -x ... release ...''
in src or created with
``./build.sh ... iso-image-source
...'' after a ``./build.sh -x ...
release sourcesets ...'' in src.
Bootable installation images
intended to be written to any
drive which appears as an sd(4)
type, such as USB flash disks.
These images are created with
``./build.sh ... install-image''
shared/ Files shared by two or more machine types.
Files which may be shared by all systems of
the same <machine_arch> will be located in
symbolic links pointing to these files from
the <machine> subdirectory.
ALL/ Files which are completely machine-independent
will be located in
.../NetBSD-<rel>/shared/ALL/ with symbolic
links pointing to these files from the
source/ Source code of the operating system should be put into
.../NetBSD-<rel>/source/ using the following layout:
sets/ Sources for the various system sets.
gnusrc.tgz Contains sources for all GPLed and possi-
bly other programs that contains restric-
tions in their licensing that prevent
others from using these programs in
sharesrc.tgz Contains machine-independent data files
that can be shared across architec-
src.tgz The operating system's userland source
code, including all programs, tools,
syssrc.tgz Kernel sources for all architectures plus
sources of the tools needed to build ker-
nels (like config(1)).
xsrc.tgz Source code of the X Window System used
on all NetBSD architectures. Includes X
clients and servers.
The binary releases in .../NetBSD-<rel>/<machine>/ fit the
INSTALL.txt Installation notes, including complete descrip-
tions of files contained within the release
INSTALL.more pretty version, suited for viewing with more(1)
INSTALL.html HTML version
INSTALL.ps PostScript version
binary/ system binaries
gzimg/ compressed system images
The primary system image
on those platforms that
provide them. These
images may not be
A bootable system image
for a particular board,
on platforms that provide
sets/ installation sets
base.tgz The base binary distribu-
tion. This set contains
the base NetBSD utilities
that are necessary for
the system to run and be
This set excludes all
things listed in the sets
comp.tgz The compiler tools dis-
tribution. This set con-
tains the C and C++ com-
linker, other toolchain
components, and their
manual pages. It also
includes the system
(/usr/include) and the
static system libraries.
etc.tgz This set contains the
files that reside in /etc
and in several other
places throughout the
file system hierarchy.
games.tgz This set includes the
games and their manual
This set includes a ker-
nel built from the
GENERIC kernel configura-
tion file. This is meant
as an example only; dif-
ferent platforms may have
differently named ker-
man.tgz This set includes all of
the manual pages for the
binaries and other soft-
ware contained in the
base set which are not
included in the other
misc.tgz This set includes miscel-
files, including dictio-
naries, the typesettable
document set, and various
other documentation and
modules.tgz This set includes all the
rescue.tgz This set contains the
tests.tgz This set includes the
tests(7) for atf(7), the
automated test framework
used by NetBSD.
text.tgz This set includes the
NetBSD text processing
groff(1), all related
programs, and their man-
xbase.tgz This set includes the
base X11 distribution,
including manual pages
and excluding everything
contained in the other
xetc.tgz This set includes X11
xcomp.tgz This set includes the X11
include files and static
xfont.tgz This set includes the X11
xserver.tgz This set includes the X
servers and manual pages
for a given machine.
Note: this set may not be
available on some
kernel/ suitably named, gzipped kernels
netbsd-GENERIC.gz A kernel built from
the GENERIC kernel
This is meant as an
example only; dif-
may have differ-
ently named ker-
installation/ installation helper items
cdrom/ CD-ROM images in ISO 9660 format,
created as part of ``build.sh ...
release ...'' in src.
Images in this directory are
bootable, and contain one a kernel,
installation tools, and rescue
tools. They do not contain instal-
lation sets, source sets, or other
components of a complete release.
Note: These images are only present
in the amd64 and i386
boot.iso VGA console
boot-com.iso Serial console
diskimage/ disk images, on those platforms
that provide them
floppy/ floppy images, on those platforms
that provide them
installation kernels for platforms
that can boot them directly
miniroot/ miniroot images, on those platforms
that provide them
misc/ miscellaneous installation helper
utilities, including boot selec-
tors, floppy writing software,
other software that runs under for-
eign operating systems, etc.
netboot/ network boot programs
tapeimage/ tape images, on those platforms
that provide them
cksum(1), dd(1), gzip(1), split(1), tar(1)
The release manual page first appeared in NetBSD 1.3.
NetBSD 10.99 July 13, 2020 NetBSD 10.99