- NetBSD Manual Pages
WWANC(4) NetBSD Kernel Interfaces Manual WWANC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
wwanc -- PCI LTE modem
wwanc* at pci? dev ? function ?
wwan* at wwanc?
The wwanc driver provides support for Fibocom L850-GL / Intel XMM7360.
The device establishes connections via cellular networks such as GPRS,
UMTS, and LTE. They appear as a regular point-to-point network inter-
face, transporting raw IP frames.
The SIM card needs to be unlocked, the wwanc driver provides no means to
provide a password for the SIM.
The following devices should work:
intro(4), netintro(4), pci(4), ifconfig.if(5), ifconfig(8), MAKEDEV(8),
Linux driver repository:
The wwanc device driver first appeared NetBSD 10.0.
Development of the Linux and OpenBSD driver was supported by genua GmbH.
The wwanc driver was written by James Wah <firstname.lastname@example.org> for
Linux, it was ported to OpenBSD and NetBSD by Jaromir Dolecek
<jdolecek@NetBSD.org> for Moritz Systems Technology Company Sp. z o.o.
The wwanc driver IPv6 support is untested.
Network initialization requires a Python script published in the Linux
driver repository, available as package pkgsrc/net/py-xmm7360. The
script requires the management device nodes to be created via:
cd /dev && ./MAKEDEV xmm0
NetBSD 9.99 July 27, 2020 NetBSD 9.99