- NetBSD Manual Pages
IX(4) NetBSD/vax Kernel Interfaces Manual IX(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ix -- Interlan Np100 10 Mb/s Ethernet interface
np0 at uba0 csr 166000 vector npintr
NOTE: This driver has not been ported from 4.4BSD yet.
The ix interface provides access to a 10 Mb/s Ethernet network through an
Interlan Np100 controller used as a link-layer interface.
This interface is unusual in that it requires loading firmware into the
controller before it may be used as a network interface. This is accom-
plished by opening a character special device, and writing data to it. A
program to load the image is provided in /usr/src/new/np100. The
sequence of commands would be:
# ./npload np.image [/dev/np<board #> if other than np00]
# sleep 10
# ifconfig ix0 ...
Each of the host's network addresses is specified at boot time with an
SIOCSIFADDR ioctl(2). The ix interface employs the address resolution
protocol described in arp(4) to dynamically map between Internet and Eth-
ernet addresses on the local network.
ix%d: Req failed, cmd %x, stat %x, ust error %x,%x. The firmware in the
controller refused to honor a request from UNIX in initializing packet
level communications. The board may need to be reset and reloaded. Or,
you may not have allowed enough time between loading the board and issu-
ing the request to begin UNIX network operation.
ix%d: can't initialize. The interface was unable to obtain UNIBUS
resources required for operation.
ix%d: failed to reinitialize DLA module. The interface got sick after
attempting to reprogram its physical Ethernet address. Try reloading the
firmware. The attempt is made only when this interfaces is not the first
one configured for XNS.
ix%d: can't handle af%d. The interface was handed a message with
addresses formatted in an unsuitable address family; the packet was
ix%d: stray xmit interrupt, npreq=%x. This may happen if the board is
reloaded while network processes are still running.
ixrint: cqe error %x, %x, %x. This will result if an ifconfig(8) request
is made at an inopportune time, such as not allowing enough time after
loading the firmware. After 100 such errors are logged, the UNIX network
driver will shut itself down, saying:
ixrint: shutting down unix dla. The recourse is to reload the firmware
and allow more time.
arp(4), inet(4), netintro(4), vax/np(4)
The ix driver appeared in 4.3BSD.
NetBSD 10.99 February 5, 2019 NetBSD 10.99