- NetBSD Manual Pages
UMB(4) NetBSD Kernel Interfaces Manual UMB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
umb -- USB Mobile Broadband Interface Model (MBIM)
umb* at uhub? port?
The umb driver provides support for USB MBIM devices.
MBIM devices establish connections via cellular networks such as GPRS,
UMTS, and LTE. They appear as a regular point-to-point network inter-
face, transporting raw IP frames.
Required configuration parameters like PIN and APN have to be set with
umbctl(8). Once the SIM card has been unlocked with the correct PIN, it
will remain in this state until the MBIM device is power-cycled. In case
the device is connected to an "always-on" USB port, it may be possible to
connect to a provider without entering the PIN again even if the system
The following devices should work:
Ericsson H5321gw and N5321gw
Medion Mobile S4222 (MediaTek OEM)
Sierra Wireless EM7345
Sierra Wireless EM7455
Sierra Wireless EM8805
Sierra Wireless MC8305
intro(4), netintro(4), usb(4), ifconfig.if(5), ifconfig(8), umbctl(8)
Universal Serial Bus Communications Class Subclass Specification for
Mobile Broadband Interface Model,
The umb device driver first appeared in OpenBSD 6.0 and NetBSD 9.0.
The umb driver was written by Gerhard Roth <firstname.lastname@example.org> and
ported from OpenBSD by Pierre Pronchery <email@example.com>.
The umb driver does not support IPv6.
Devices which fail to provide a conforming MBIM implementation will prob-
ably be attached as some other driver, such as u3g(4).
NetBSD 10.99 August 24, 2019 NetBSD 10.99