tty(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
TTY(4)                  NetBSD Kernel Interfaces Manual                 TTY(4)


NAME
tty -- general terminal interface
SYNOPSIS
#include <sys/ioctl.h>
DESCRIPTION
This section describes the interface to the terminal drivers in the sys- tem. Terminal Special Files Each hardware terminal port on the system usually has two terminal spe- cial device files associated with it in the directory /dev/ (for example, /dev/tty03 and /dev/dty03). The /dev/ttyXX special file is used for dial-in modems and terminals. When a user logs into the system on one of these hardware terminal ports, the system has already opened the associated device and prepared the line for normal interactive use (see getty(8)). The /dev/dtyXX special file is a SunOS-compatible dial-out device. Unlike the dial-in device, opening the dial-out device never blocks. If the corresponding dial-in device is already opened (not blocked in the open waiting for carrier), then the dial-out open will fail immediately; otherwise it will succeed immediately. While the dial-out device is open, the dial-in device may not be opened. If the dial-in open is blocking, it will wait until the dial-out device is closed (and carrier is detected); otherwise it will fail immediately. There is also a special case of a terminal file that connects not to a hardware terminal port, but to another program on the other side. These special terminal devices are called ptys (pseudo terminals) and provide the mechanism necessary to give users the same interface to the system when logging in over a network (using rlogin(1), or telnet(1) for exam- ple.) Even in these cases the details of how the terminal file was opened and set up is already handled by special software in the system. Thus, users do not normally need to worry about the details of how these lines are opened or used. Also, these lines are often used for dialing out of a system (through an out-calling modem), but again the system pro- vides programs that hide the details of accessing these terminal special files (see tip(1)). When an interactive user logs in, the system prepares the line to behave in a certain way (called a line discipline), the particular details of which is described in stty(1) at the command level, and in termios(4) at the programming level. A user may be concerned with changing settings associated with his particular login terminal and should refer to the preceding man pages for the common cases. The remainder of this man page is concerned with describing details of using and controlling terminal devices at a low level, such as that possibly required by a program wish- ing to provide features similar to those provided by the system. Line disciplines A terminal file is used like any other file in the system in that it can be opened, read, and written to using standard system calls. For each existing terminal file, there is a software processing module called a line discipline associated with it. The line discipline essentially glues the low level device driver code with the high level generic inter- face routines (such as read(2) and write(2)), and is responsible for implementing the semantics associated with the device. When a terminal file is first opened by a program, the default line discipline called the termios line discipline is associated with the file. This is the primary line discipline that is used in most cases and provides the semantics that users normally associate with a terminal. When the termios line discipline is in effect, the terminal file behaves and is operated according to the rules described in termios(4). Please refer to that man page for a full description of the terminal semantics. The operations described here generally represent features common across all line disciplines, however some of these calls may not make sense in conjunc- tion with a line discipline other than termios, and some may not be sup- ported by the underlying hardware (or lack thereof, as in the case of ptys). Terminal File Operations All of the following operations are invoked using the ioctl(2) system call. Refer to that man page for a description of the request and argp parameters. In addition to the ioctl requests defined here, the specific line discipline in effect will define other requests specific to it (actually termios(4) defines them as function calls, not ioctl requests.) The following section lists the available ioctl requests. The name of the request, a description of its purpose, and the typed argp parameter (if any) are listed. For example, the first entry says TIOCSLINED char name[32] and would be called on the terminal associated with file descriptor zero by the following code fragment: ioctl(0, TIOCSLINED, "termios"); Terminal File Request Descriptions TIOCSLINED char name[32] Change to the new line discipline called name. TIOCGLINED char name[32] Return the current line discipline in the string pointed to by name. TIOCSBRK void Set the terminal hardware into BREAK condition. TIOCCBRK void Clear the terminal hardware BREAK condition. TIOCSDTR void Assert data terminal ready (DTR). TIOCCDTR void Clear data terminal ready (DTR). TIOCGPGRP int *tpgrp Return the current process group the terminal is associated with in the integer pointed to by tpgrp. This is the under- lying call that implements the tcgetpgrp(3) call. TIOCSPGRP int *tpgrp Associate the terminal with the process group (as an integer) pointed to by tpgrp. This is the underlying call that imple- ments the tcsetpgrp(3) call. TIOCGETA struct termios *term Place the current value of the termios state associated with the device in the termios structure pointed to by term. This is the underlying call that implements the tcgetattr(3) call. TIOCSETA struct termios *term Set the termios state associated with the device immediately. This is the underlying call that implements the tcsetattr(3) call with the TCSANOW option. TIOCSETAW struct termios *term First wait for any output to complete, then set the termios state associated with the device. This is the underlying call that implements the tcsetattr(3) call with the TCSADRAIN option. TIOCSETAF struct termios *term First wait for any output to complete, clear any pending input, then set the termios state associated with the device. This is the underlying call that implements the tcsetattr(3) call with the TCSAFLUSH option. TIOCOUTQ int *num Place the current number of characters in the output queue in the integer pointed to by num. TIOCSTI char *cp Simulate typed input. Pretend as if the terminal received the character pointed to by cp. TIOCNOTTY void This call is obsolete but left for compatibility. In the past, when a process that didn't have a controlling terminal (see The Controlling Terminal in termios(4)) first opened a terminal device, it acquired that terminal as its controlling terminal. For some programs this was a hazard as they didn't want a controlling terminal in the first place, and this pro- vided a mechanism to disassociate the controlling terminal from the calling process. It must be called by opening the file /dev/tty and calling TIOCNOTTY on that file descriptor. The current system does not allocate a controlling terminal to a process on an open() call: there is a specific ioctl called TIOCSCTTY to make a terminal the controlling terminal. In addition, a program can fork() and call the setsid() sys- tem call which will place the process into its own session - which has the effect of disassociating it from the control- ling terminal. This is the new and preferred method for pro- grams to lose their controlling terminal. TIOCSTOP void Stop output on the terminal (like typing ^S at the keyboard). TIOCSTART void Start output on the terminal (like typing ^Q at the key- board). TIOCSCTTY void Make the terminal the controlling terminal for the process (the process must not currently have a controlling terminal). TIOCDRAIN void Wait until all output is drained. TIOCEXCL void Set exclusive use on the terminal. No further opens are per- mitted except by root. Of course, this means that programs that are run by root (or setuid) will not obey the exclusive setting - which limits the usefulness of this feature. TIOCNXCL void Clear exclusive use of the terminal. Further opens are per- mitted. TIOCFLUSH int *what If the value of the int pointed to by what contains the FREAD bit as defined in <sys/fcntl.h>, then all characters in the input queue are cleared. If it contains the FWRITE bit, then all characters in the output queue are cleared. If the value of the integer is zero, then it behaves as if both the FREAD and FWRITE bits were set (i.e. clears both queues). TIOCGWINSZ struct winsize *ws Put the window size information associated with the terminal in the winsize structure pointed to by ws. The window size structure contains the number of rows and columns (and pixels if appropriate) of the devices attached to the terminal. It is set by user software and is the means by which most full- screen oriented programs determine the screen size. The winsize structure is defined in <sys/ioctl.h>. TIOCSWINSZ struct winsize *ws Set the window size associated with the terminal to be the value in the winsize structure pointed to by ws (see above). TIOCGQSIZE int *qsize Get the current size of the tty input and output queues. TIOCSQSIZE int *qsize Set the size of the tty input and output queues. Valid sizes are between 1024 and 65536 and input values are converted to a power of two. All pending input and output is dropped. TIOCCONS int *on If on points to a non-zero integer, redirect kernel console output (kernel printf's) to this terminal. If on points to a zero integer, redirect kernel console output back to the nor- mal console. This is usually used on workstations to redi- rect kernel messages to a particular window. TIOCMSET int *state The integer pointed to by state contains bits that correspond to modem state. Following is a list of defined variables and the modem state they represent: TIOCM_LE Line Enable. TIOCM_DTR Data Terminal Ready. TIOCM_RTS Request To Send. TIOCM_ST Secondary Transmit. TIOCM_SR Secondary Receive. TIOCM_CTS Clear To Send. TIOCM_CAR Carrier Detect. TIOCM_CD Carrier Detect (synonym). TIOCM_RNG Ring Indication. TIOCM_RI Ring Indication (synonym). TIOCM_DSR Data Set Ready. This call sets the terminal modem state to that represented by state. Not all terminals may support this. TIOCMGET int *state Return the current state of the terminal modem lines as rep- resented above in the integer pointed to by state. TIOCMBIS int *state The bits in the integer pointed to by state represent modem state as described above, however the state is OR-ed in with the current state. TIOCMBIC int *state The bits in the integer pointed to by state represent modem state as described above, however each bit which is on in state is cleared in the terminal. TIOCSFLAGS int *state The bits in the integer pointed to by state contain bits that correspond to serial port state. Following is a list of defined flag values and the serial port state they represent: TIOCFLAG_SOFTCAR Ignore hardware carrier. TIOCFLAG_CLOCAL Set the termios(4) CLOCAL flag on open. TIOCFLAG_CRTSCTS Set the termios(4) CRTSCTS flag on open. TIOCFLAG_MDMBUF Set the termios(4) MDMBUF flag on open. This call sets the serial port state to that represented by state. Not all serial ports may support this. TIOCGFLAGS int *state Return the current state of the serial port as represented above in the integer pointed to by state.
COMPATIBILITY
Two ioctls are maintained for backwards compatibility. They provide methods to get and set the current line discipline, but are not extensi- ble. TIOCSETD int *ldisc Change to the new line discipline pointed to by ldisc. The old list of available line disciplines are listed in <sys/ttycom.h> and are: TTYDISC Termios interactive line discipline. TABLDISC Tablet line discipline. SLIPDISC Serial IP line discipline. PPPDISC Point to Point Protocol line discipline. STRIPDISC Starmode Radio IP line discipline. TIOCGETD int *ldisc Return the current line discipline in the integer pointed to by ldisc.
SEE ALSO
stty(1), ioctl(2), tcgetattr(3), tcsetattr(3), ttyaction(3), pty(4), termios(4), ttys(5), getty(8), linedisc(9)
HISTORY
A console typewriter device /dev/tty and asynchronous communication interfaces /dev/tty[0-5] first appeared in Version 1 AT&T UNIX. Separate dial-out device files were implemented in SunOS 4. They were cloned by Charles M. Hannum for NetBSD 1.4. NetBSD 10.99 September 7, 2019 NetBSD 10.99
Powered by man-cgi (2024-03-18). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.