- NetBSD Manual Pages
NETWORKS(5) NetBSD File Formats Manual NETWORKS(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
networks -- Internet Protocol network name data base
The networks file is used as a local source to translate between Internet
Protocol (IP) network addresses and network names (and vice versa). It
can be used in conjunction with the DNS, as controlled by
While the networks file was originally intended to be an exhaustive list
of all IP networks that the local host could communicate with, distribu-
tion and update of such a list for the world-wide Internet (or, indeed,
for any large "enterprise" network) has proven to be prohibitive, so the
Domain Name System (DNS) is used instead, except as noted.
For each IP network a single line should be present with the following
name network [alias ...]
name Official network name
network IP network number
alias Network alias
Items are separated by any number of blanks and/or tab characters. A
``#'' indicates the beginning of a comment; characters up to the end of
the line are not interpreted by routines which search the file.
Network number may be specified in the conventional dot (``.'') notation
using the inet_network(3) routine from the IP address manipulation
library, inet(3). Network names may contain "a" through "z", zero
through nine, and dash.
IP network numbers on the Internet are generally assigned to a site by
its Internet Service Provider (ISP), who, in turn, get network address
space assigned to them by one of the regional Internet Registries (e.g.
ARIN, RIPE NCC, APNIC). These registries, in turn, answer to the Inter-
net Assigned Numbers Authority (IANA).
If a site changes its ISP from one to another, it will generally be
required to change all its assigned IP addresses as part of the conver-
sion; that is, return the previous network numbers to the previous ISP,
and assign addresses to its hosts from IP network address space given by
the new ISP. Thus, it is best for a savvy network manager to configure
their hosts for easy renumbering, to preserve their ability to easily
change their ISP should the need arise.
/etc/networks The networks file resides in /etc.
getnetent(3), nsswitch.conf(5), resolv.conf(5), hostname(7), dhcpcd(8),
Classless IN-ADDR.ARPA delegation, RFC 2317, March 1998.
Address Allocation for Private Internets, RFC 1918, February 1996.
Network 10 Considered Harmful, RFC 1627, July 1994.
Classless Inter-Domain Routing (CIDR): an Address Assignment and
Aggregation Strategy, RFC 1519, September 1993.
DNS Encoding of Network Names and Other Types, RFC 1101, April 1989.
The networks file format appeared in 4.2BSD.
NetBSD 10.99 July 14, 2018 NetBSD 10.99