- NetBSD Manual Pages
FD(4) NetBSD/sparc64 Kernel Interfaces Manual FD(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
fdc -- Sun SPARCstation i82072 or i82077 floppy disk controller driver
fdc0 at sbus0 (SBus based machines)
fdc0 at ebus0 (PCI based machines)
fd* at fdc0
This is the driver for the built-in floppy disk drive run by the Intel
i82072 or i82077 controller chip found on the SPARCstation desktop sys-
tems, and other SPARC systems.
Bits [0-3] of the minor device number of the special files referring to
this device encode the floppy density as follows:
0 3.5'' 1.44MB floppy diskettes.
1 3.5'' 720KB floppy diskettes.
2 3.5'' 360KB floppy diskettes.
3 3.5'' 1.2MB/NEC Japanese format floppy diskettes.
The driver supports floppy disk formatting using the interfaces in
FDIOCGETFORMAT struct fdformat_parms
Fetch current formatting parameters. This gets the
default parameters for the open device if no parame-
ters have been set during the session.
FDIOCSETFORMAT struct fdformat_parms
Set formatting parameters. The driver saves this
state and it persists while the device is open.
FDIOCFORMAT_TRACK struct fdformat_cmd
Format a track on the medium. If this call returns
EINVAL, the track formatting parameters were out of
range for the medium. If it returns EIO, there was a
medium error while formatting the track.
FDIOCSETOPTS int Set driver options which persist until the device is
closed. The options should be the logical OR of the
desired values below:
FDOPT_NORETRY Do not retry operations on failure
FDOPT_SILENT Do not print error messages to the con-
FDIOCGETOPTS int Fetch drive options.
A typical use of the formatting facilities would be to open the device,
call FDIOCGETFORMAT to fetch the current format parameters, perhaps
change a parameter or two, display the formatting details to the user,
and then call FDIOCSETFORMAT followed by a series of calls to
The fdc driver first appeared in NetBSD 4.0.
The ebus attachment does not yet work.
NetBSD 9.99 May 8, 2007 NetBSD 9.99