- NetBSD Manual Pages
ENVCTRL(4) NetBSD/sparc64 Kernel Interfaces Manual ENVCTRL(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
envctrl -- Sun Ultra Enterprise 450 environmental monitoring
envctrl* at ebus?
The envctrl driver provides thermal monitoring of processors and power
supplies, as well as automatic fan regulation. The driver attaches to the
SUNW,envctrl subsystem found on Ultra Enterprise 450 systems.
The following sensors can be queried with envstat(8):
Sensor Units Description
CPU0 degC Processor 0 temperature
CPU1 degC Processor 1 temperature
CPU2 degC Processor 2 temperature
CPU3 degC Processor 3 temperature
PS0 degC Power supply 0 temperature
PS1 degC Power supply 1 temperature
PS2 degC Power supply 2 temperature
ambient degC Ambient temperature
cpufan voltage V Voltage used to drive processor fans
psfan voltage V Voltage used to drive power supply fans
ps failed count number of failed power supplies
fans failed count number of failed fans
The envctrl driver first appeared in NetBSD 5.0.
Tobias Nygren <tnn@NetBSD.org>
The driver doesn't support SUNW,envctrltwo found on the Ultra Enterprise
Environmental interrupts are not supported.
NetBSD 9.99 April 14, 2007 NetBSD 9.99