- NetBSD Manual Pages
URNDIS(4) NetBSD Kernel Interfaces Manual URNDIS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
urndis -- USB Remote NDIS Ethernet device
urndis* at uhub?
The urndis driver provides support for Ethernet access over Remote NDIS.
The urndis driver should work with all USB RNDIS devices, but the follow-
ing devices are known to work:
· Geeksphone ONE
· Google Nexus One
· HTC Desire
· HTC Dream / T-Mobile G1 / ADP1
· HTC Hero
· HTC Magic
· HTC Tattoo
· HTC Wildfire
· LGE Nexus 5
· Motorola Moto X (2nd Gen.)
· OnePlus 5T
· Samsung Galaxy S / S2
· Samsung Galaxy S8 Active
· Sony Xperia XA2
The urndis driver does not support different media types or options. For
more information on configuring this device, see ifconfig(8).
See usbnet(4) for diagnostics.
arp(4), intro(4), netintro(4), usb(4), usbnet(4), ifconfig.if(5),
The urndis device driver first appeared in OpenBSD 4.7 and in NetBSD 6.0.
The urndis driver was written by Jonathan Armani <email@example.com>,
Michael Knudsen <firstname.lastname@example.org>, and Fabien Romano <email@example.com>.
NetBSD 10.99 February 12, 2023 NetBSD 10.99