- NetBSD Manual Pages
INTRO(4) NetBSD/macppc Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to macppc special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
MACPPC DEVICE SUPPORT
This section describes the hardware supported on the Power Macintosh.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in macppc/autoconf(4). A list
of the supported devices is given below.
config(1), gem(4), macppc/autoconf(4), macppc/awacs(4), macppc/bm(4),
The macppc intro man page first appeared in NetBSD 1.5.1, based on the
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
PCMCIA devices are supported through the pcmcia(4) bus and associated
Cardbus devices are supported through the cardbus(4) bus and associated
USB devices are supported through the usb(4) bus and associated devices.
Additionally, the following specific devices are supported:
adb Apple Desktop Bus event interface.
awacs Audio Waveform Amplifier and Converter -- Apple Sound
Chip (supported systems include 603 and 604 based
machines, and Open Firmware 3 based machines).
bm BMac Ethernet.
de DECchip 21x4x based Ethernet cards (see also tlp(4)).
esp NCR 53C9x built-in SCSI interface.
gm GMac Ethernet.
kmem kernel virtual memory.
mc MACE Ethernet.
mem physical memory.
mesh MESH built-in SCSI interface (most Old World machines up
to the 1999 series of G3 PowerBooks).
nvram NVRAM access.
ofb PCI based frame buffer with Open Firmware support.
openfirm Open Firmware access.
tlp DECchip 21x4x based Ethernet cards.
wdc Standard on-board IDE controller.
zsc Zilog Z8530 built-in serial interface.
NetBSD 9.99 February 17, 2017 NetBSD 9.99