- NetBSD Manual Pages
HVN(4) NetBSD Kernel Interfaces Manual HVN(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
hvn -- Hyper-V networking interface
hvn* at vmbus?
The hvn driver provides support for a Network Virtual Service Client
(NetVSC), a virtual networking interface that relays device requests to
the Virtual Service Provider (VSP) in the management operating system via
NetVSC emulates an RNDIS 1.0 compliant device on top of a custom NVS pro-
tocol operating over the VMBus channel ring.
Individual networking interfaces can be renamed by issuing a
Rename-VMNetworkAdapter PowerShell command in the management domain. In
order to enable sending and receiving of IEEE 802.1q (VLAN) frames, the
virtual port needs to be put into Trunk mode with the
arp(4), netintro(4), vlan(4), ifconfig(8)
The hvn driver first appeared in OpenBSD 6.1 and appeared in NetBSD 8.0.
The hvn driver was written by Mike Belopuhov <firstname.lastname@example.org> based on
the FreeBSD driver by the Microsoft BSD Integration Services Team
<email@example.com> and ported to NetBSD by
NetBSD 10.99 October 12, 2021 NetBSD 10.99