- NetBSD Manual Pages
VCHIQ(4) NetBSD Kernel Interfaces Manual VCHIQ(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vchiq -- Broadcom VideoCore Host Interface device driver
vchiq* at simplebus?
vchiq* at acpi?
The vchiq driver provides support for the VideoCore 4 GPU messaging
interface in Broadcom SoCs found in boards such as the Raspberry Pi.
Libraries in pkgsrc provide OpenGL ES support and video decoding acceler-
ation for the VideoCore 4 using the /dev/vchiq interface exposed to user-
Audio output support is provided by the kernel through vcaudio(4), which
uses this messaging interface to the GPU internally.
Debugging information may be obtained reading the device with cat(1).
Information such as slots and usage by particular functions of the Video-
Core 4 device are displayed.
cat(1), acpi(4), bcmgpio(4), vcaudio(4),
The vchiq device driver appeared in NetBSD 7.0.
/dev/vchiq does not follow the standard model for graphical acceleration
on Unix-like systems, so applications have to be specially built to take
advantage of it. The interface to userland also cannot be exposed by
64-bit or big endian kernels due to problems in the upstream Broadcom
NetBSD 9.99 December 11, 2021 NetBSD 9.99