- NetBSD Manual Pages
ALTQ(4) NetBSD Kernel Interfaces Manual ALTQ(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
altq -- alternate queuing framework
The altq system is a framework which provides several disciplines for
queuing outgoing network packets. While traffic shaping is perhaps the
most prominent example, altq provides also other measures related to QoS.
The framework has been integrated to the pf(4) packet filter since
At the implementation level altq modifies the interface packet queues.
Therefore the driver modifications described in altq(9) are required in
order to use a certain network card with altq.
pf(4), altq.conf(5), altqd(8), altq(9)
Kenjiro Cho, Fitting theory into reality in the ALTQ case,
2004, Asia BSD conference.
The altq system first appeared in March 1997 and found its home in the
KAME project http://www.kame.net: (). It was imported into NetBSD 1.6.
Please note that you must compile pf(4) in the kernel, using the PF
module(7) alongside altq built in the kernel will not work.
NetBSD 10.99 March 20, 2018 NetBSD 10.99