- NetBSD Manual Pages
INTRO(4) NetBSD Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to emips special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
This section describes the hardware supported on eMIPS (Microsoft Exten-
sible MIPS processor)-based platforms. Software support for these
devices comes in two forms. A hardware device may be supported with a
character or block device driver, or it may be used within the networking
subsystem and have a network interface driver. Block and character
devices are accessed through files in the file system of a special type;
see mknod(8). Network interfaces are indirectly accessed through the
interprocess communication facilities provided by the system; see
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system must be rebooted.
The autoconfiguration system is described in emips/autoconf(4). A list
of the supported devices is given below.
The following systems are supported:
BeSquare BErkeley Emulation System-3 FPGA development board
known as the "BEE3". This is a quad-chip FPGA system
where eMIPS can run on each FPGA separately, on multiple
FPGAs in concert, and in multi-processor configurations.
Xilinx University Program board
known as "XUP". This is the Xilinx reference board for
the Virtex-5 series chips. It can use the same XL110T
FPGA chip present on the BEE3.
Xilinx reference board for the Virtex-4 series chip,
including the SX35.
Same as the above, but with the smaller LX25 chip.
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
ace Xilinx SystemACE interface for Compact-FLASH cards, bears
similarities to the IDE interface. Present on XUP and
ML40x boards. Not present on BEE3.
dz serial driver for the eMIPS console serial device.
Present on all systems.
enic Ethernet driver for the eNIC device. Present on XUP and
BEE3 systems. Not present on ML40x systems.
eclock System clock, must be configured on all systems.
ebus Extensible BUS, present on all systems.
This eMIPS intro appeared in NetBSD 6.0.
NetBSD 9.99 February 17, 2017 NetBSD 9.99