- NetBSD Manual Pages
ATPPC(4) NetBSD Kernel Interfaces Manual ATPPC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
atppc -- driver for AT-style parallel port chip sets
atppc* at acpi?
atppc* at isa? port 0x378 irq 7 drq 3 flags 0x00
atppc* at isapnp?
atppc* at ofisa?
atppc* at pnpbios? index ?
atppc* at puc? port ?
atppc supports parallel ports and provides the low level support needed
by higher level drivers such as ppbus(4). This driver attaches where the
traditional NetBSD lpt(4) driver would ordinarily. It provides the data
transport and chip set manipulation needed by higher driver layers, such
as ppbus(4) and lpt(4). This driver is designed to be one of many possi-
ble implementations supporting machine independent parallel device sup-
port via ppbus(4).
IEEE 1284 support
atppc is intended to provide to data-link like services to higher level
IEEE 1284 device drivers (such as ppbus(4)). atppc does not directly
support IEEE 1284 features such as mode negotiation but rather provides
the necessary infrastructure to allow a higher level driver to provide
atppc does provide chip set manipulation, device handshakes (where appro-
priate), low-level error detection, and data transfer.
Supported data transfer modes
atppc supports the following data transfer modes: Centronics Compatible
(Standard), Nibble, Byte (PS2), Fast Centronics, ECP, and EPP. Standard
and Fast Centronics modes are write only, Nibble and Byte modes are read
only, and ECP and EPP modes are bidirectional.
acpi(4), i386/pnpbios(4), isa(4), isapnp(4), lpt(4), ofisa(4), ppbus(4),
The atppc driver is based on the ppc driver, which originally appeared in
FreeBSD. The driver was ported over in NetBSD 2.0.
This manual page is based on the FreeBSD ppc manual page. The informa-
tion has been updated for the NetBSD port by Gary Thorpe.
The FreeBSD driver includes support for some specific chip sets, specifi-
cally detection of some non-standard device I/O locations on the ISA bus.
This support was not ported over to the NetBSD version of the driver yet.
NetBSD 9.99 August 31, 2018 NetBSD 9.99