- NetBSD Manual Pages
PCPPI(4) NetBSD Kernel Interfaces Manual PCPPI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pcppi -- PC (ISA) control port driver
pcppi* at acpi?
pcppi* at isa?
isabeep* at pcppi?
sysbeep* at pcppi?
spkr0 at pcppi?
midi* at pcppi?
The pcppi driver handles resource allocation and device attachment for
the ports related to the ISA speaker in the traditional PC/AT ``design''.
These are the ``system control port'' (which was implemented by the 8255
``PPI'' in the XT, hence the name of this driver) at IO address 0x61.
When associated with an attimer(4) device, it is possible to change the
pitch of the sounds emitted through pcppi.
The pcppi driver provides its child devices with the ability to output
simple tones through the PC speaker. The speaker(4) and midi(4) devices
use this to synthesize sounds. The isabeep(4) and sysbeep(4) devices are
helpers which the pckbd(4) driver uses as a substitute for a ``keyboard
beep'', because the PC keyboard hardware doesn't provide this.
acpi(4), attimer(4), isa(4), midi(4), pckbd(4), speaker(4)
NetBSD 9.3 March 22, 2005 NetBSD 9.3