- NetBSD Manual Pages
VFS(9) NetBSD Kernel Developer's Manual VFS(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vfs -- kernel interface to file systems
The virtual file system, vfs, is the kernel interface to file systems.
The interface specifies the calls for the kernel to access file systems.
It also specifies the core functionality that a file system must provide
to the kernel.
The focus of vfs activity is the vnode and is discussed in vnode(9).
File system operations such as mounting and syncing are discussed in
intro(9), vfsops(9), vnode(9), vnodeops(9)
NetBSD 9.1 September 22, 2001 NetBSD 9.1