- NetBSD Manual Pages
GSC(4) NetBSD/hppa Kernel Interfaces Manual GSC(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
gsc -- General System Connect bus on HP 9000/700 machines
gsc* at lasi?
gsc* at asp?
gsc* at wax?
This is the core I/O bus for all HP 9000/700 workstations. All I/O sub-
systems connect to this bus. The devices can be either on separate
chips, expansion cards or on an integrated megacell, like the LASI MBA.
The GSC bus is a 32-bit wide, address and data multiplexed bus. In its
"standard" implementation it has a maximum throughput of 160MB/s, the
"2x" implementation reaches up to 250MB/s. Some HPPA CPUs directly
attach to this bus, namely the PA7100LC and PA7300LC.
As for the expansion cards, there are different form-factors, depending
on bus-speed (standard or 2x) and specific models. The standard formfac-
tor is the "EISA form-factor"; cards that look like typical EISA cards
with a different connector (100-pin female EBBL). The Series 712 have
their own special type of GSC expansion cards, called the "GIO form-fac-
tor", which is quite small and mostly has only one VLSI chip on it (in
most cases LASI/WAX). Newer systems sometimes feature the "HSC formfac-
tor", which is a 1U-VME card-like expansion card with a 100-pin male
pin+socket connector. Mixing cards with different speeds is supported
but downgrades the performance of the whole I/O-subsystem.
The system includes machine-dependent GSC drivers, sorted by driver name:
com(4) RS-232 ports.
PC-style keyboard controller.
hil(4) Human Interface Loop, for HP-proprietary input
devices like keyboard and mice.
iee(4) Intel i82596 DX/CA 32-bit LAN coprocessor.
lpt(4) Centronics printer port.
oosiop(4) Symbios/NCR 53C700 SCSI I/O Processor.
osiop(4) Symbios/NCR 53C710 SCSI I/O Processor.
Some of these GSC devices also have PCI, EISA, or ISA equivalents. These
are listed in pci(4), eisa(4), or isa(4).
hppa/asp(4), hppa/cpu(4), hppa/intro(4), hppa/lasi(4), hppa/wax(4)
The gsc driver appeared in OpenBSD 2.6. It was ported to NetBSD 1.6 by
NetBSD 9.0 February 17, 2017 NetBSD 9.0