- NetBSD Manual Pages
CNW(4) NetBSD Kernel Interfaces Manual CNW(4)
Powered by man-cgi 1.15, Panagiotis Christias
cnw -- Netwave AirSurfer wireless network driver
cnw* at pcmcia? function ?
The cnw interface provides access to a theoretical 1 Mb/s wireless Ether-
net network based on the Netwave AirSurfer Wireless LAN (formerly known
as the Xircom Netwave Wireless LAN).
Note that the driver does not support newer devices such as the Netwave
AirSurfer ``Plus'', or the BayStack 650/660. These devices are supported
by the awi(4) driver.
Netwave devices are not compatible with IEEE 802.11 wireless networks.
Also note that there are Netwave devices with different wireless fre-
quency, depending on the radio band plan in each country.
The card uses 36K of I/O memory mapped to the card. You may need to
increase memory space available to the PCMCIA controller. See pcmcia(4)
In use, the cards appear to achieve up to a 420Kb/s transfer rate, though
a transfer rate between 250Kb/s and 350Kb/s is typical.
The card operates in the 2.4GHz frequency range and is subject to inter-
ference from microwaves, IEEE 802.11 wireless network devices, as well as
earth. For example, it seems that IEEE 802.11 channel 14 conflicts with
Netwave (US frequency). They interfere with each other if they are both
operated in the same geographic region, causing weird packet loss. You
may be able to avoid the interference with IEEE 802.11 devices, by chang-
ing the IEEE 802.11 channel.
Cards supported by the cnw driver include:
Xircom CreditCard Netwave
cnw0: can't map memory Indicates that the driver was not able to allo-
cate enough PCMCIA bus address space into which to map the device. See
pcmcia(4) and increase memory available to the PCMCIA controller.
arp(4), awi(4), inet(4), intro(4), pcmcia(4), cnwctl(8)
NetBSD 8.1 January 5, 1997 NetBSD 8.1
Modified for NetBSD
by Kimmo Suominen