- NetBSD Manual Pages
INTRO(4) NetBSD/i386 Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to i386 special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
This section describes the hardware supported on the i386 (PC-clone)
platform. Software support for these devices comes in two forms. A
hardware device may be supported with a character or block device driver,
or it may be used within the networking subsystem and have a network
interface driver. Block and character devices are accessed through files
in the file system of a special type; see mknod(8). Network interfaces
are indirectly accessed through the interprocess communication facilities
provided by the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system must be rebooted.
The autoconfiguration system is described in i386/autoconf(4). A list of
the supported devices is given below.
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
Standard builtin devices:
com NS8250-, NS16450-, and NS16550-based asynchronous serial
communications device interface
lpt Parallel port device interface
fdc Standard NEC 765 floppy disk controller.
mca MCA I/O bus.
mem Main memory interface
pci PCI I/O bus.
eisa EISA I/O bus, either as main bus or via PCI-EISA bridge.
isa ISA bus and ISA devices, either as main bus or via PCI-ISA
isa isa I/O bus.
isapnp ``bus'' for ISA devices with PnP support.
speaker console speaker device interface
PCMCIA devices are supported through the pcmcia(4) bus and associated
Cardbus devices are supported through the cardbus(4) bus and associated
USB devices are supported through the usb(4) bus and associated device
Console devices using ISA, EISA, or PCI video adaptors and standard AT or
PS/2 keyboards are supported by the machine independent wscons(4) console
Disk, tape and SCSI devices:
aha Adaptec 154x ISA SCSI adapter boards.
ahb Adaptec 1742 EISA SCSI adapter boards.
ahc Adaptec 274x, 284x, 2940 and 3940 VL/EISA/PCI SCSI adapter
aic Adaptec AIC-6260, Adaptec AIC-6360, Adaptec 152x, and
SoundBlaster SCSI boards.
bha Buslogic BT-445 (ISA), BT-74x (EISA), and BT-9
(PCI) SCSI boards.
mcd Mitsumi CD-ROM drives.
ncr Symbios (formerly NCR) PCI SCSI adapter boards.
pciide PCI IDE controllers.
sea Seagate/Future Domain SCSI cards. ST01/02, Future Domain
TMC-885, and Future Domain TMC-950.
uha Ultrastor ISA and EISA SCSI adapter cards. Ultrastore
14f, Ultrastore 34f, and Ultrastore 24f.
wdc Standard ISA Western Digital type hard drives controllers.
MFM, RLL, ESDI, and IDE.
wt Wangtek and compatible ISA controllers for QIC-02 and
de Ethernet driver for dc21040, dc21042, and dc21140-based
10Mbit and 100Mbit PCI Ethernet adaptors, including
DE-430, DE-450 DE-500, SMC EtherPower, and Znyx.
FDDI driver for Digital DEFEA (EISA) and DEFPA FDDI adap-
ed Western Digital/SMC 80x3 and Ultra, 3Com 3c503, and Novell
NE1000 and 2000 Ethernet interface
eg 3Com 3c505 Ethernet board.
el 3Com 3c501 Ethernet board.
ep 3Com EtherLink III (3c5x9) Ethernet interface
ie Ethernet driver for the AT&T StarLAN 10, EN100, StarLan
Fiber, and 3Com 3c507.
iy Ethernet driver for the ISA Intel EtherExpress PR0/10
le Ethernet driver for BICC Isolan, Novell NE2100, Digital
DEPCA cards, and PCnet-PCI cards.
tl Ethernet driver for ThunderLAN-based Ethernet adaptor.
Serial communication cards:
ast multiplexing serial communications card first made by AST.
boca Boca BB100 and BB2016 multiplexing serial communica-
tions cards. NS8250-, NS16450-, and NS16550-based asyn-
chronous serial communications device interface, or
internal modems that provide a serial-chip compatible
cy Cyclades Cyclom-4Y, -8Y, and -16Y asynchronous serial com-
munications device interface
rtfps a multiplexing serial communications card derived from IBM
gus Gravis Ultrasound non-PnP soundcards.
guspnp Gravis Ultrasound PnP soundcards.
pas ProAudio Spectrum soundcards.
pss Personal Sound System-compatible soundcards, including
Cardinal Digital SoundPro 16 and Orchid Soundwave 32.
sb Soundblaster, Soundblaster 16, and Soundblaster Pro sound-
wss Windows Sound System-compatible sound cards based on the
Mouse and pointer devices:
joy joystick game adaptor
lms Logitech-style bus mouse device interface
mms Microsoft-style bus mouse device interface
pms PS/2 auxiliary port mouse device interface
Serial mice can be configured on any supported serial port.
config(1), i386/autoconf(4), netintro(4)
The i386 intro appeared in NetBSD 1.0.
NetBSD 8.1 February 17, 2017 NetBSD 8.1