- NetBSD Manual Pages
RUMP_MSDOS(8) NetBSD System Manager's Manual RUMP_MSDOS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_msdos -- mount a msdos image with a userspace server
rump_msdos [options] image mountpoint
NOTE! This manual page describes features specific to the rump(3) file
server. Please see mount_msdos(8) for a full description of the avail-
able command line options.
The rump_msdos utility can be used to mount msdos file systems. It uses
rump(3) and p2k(3) to facilitate running the file system as a server in
userspace. As opposed to mount_msdos(8), rump_msdos does not use file
system code within the kernel and therefore does not require kernel sup-
port except puffs(4). Apart from a minor speed penalty there is no down-
side with respect to in-kernel code.
rump_msdos does not require using vnconfig(8) for mounts from regular
files and the file path can be passed directly as the image parameter.
In fact, the use of vnconfig(8) is discouraged, since it is unable to
properly deal with images on sparse files.
In case the image contains multiple partitions, the desired partition
must be indicated by appending the token ``%DISKLABEL:p%'' to the image
path. The letter ``p'' specifies the partition as obtained via
disklabel(8). For example, to mount partition ``e'' from image
/tmp/wd0.img, use ``/tmp/wd0.img%DISKLABEL:e%''.
It is recommended that untrusted file system images be mounted with
rump_msdos instead of mount_msdos(8). Corrupt file system images com-
monly cause the file system to crash the entire kernel, but with
rump_msdos only the userspace server process will dump core.
To use rump_msdos via mount(8), the flags -o rump and -t msdos should be
given. Similarly, rump_msdos is used instead of mount_msdos(8) if
``rump'' is added to the options field of fstab(5).
p2k(3), puffs(3), rump(3), mount_msdos(8)
The rump_msdos utility first appeared in NetBSD 5.0.
NetBSD 7.0 November 21, 2010 NetBSD 7.0