workqueue_enqueue(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
WORKQUEUE_ENQUEUE(9)   NetBSD Kernel Developer's Manual   WORKQUEUE_ENQUEUE(9)


NAME
workqueue_enqueue -- Enqueue a work for later processing
SYNOPSIS
#include <sys/workqueue.h> void workqueue_enqueue(struct workqueue *wq, struct work *wk, struct cpu_info *ci);
DESCRIPTION
Enqueue the work wk into the workqueue wq. If the WQ_PERCPU flag was set on workqueue creation, the ci argument may be used to specify the CPU on which the work should be enqueued. Also it may be NULL, then work will be enqueued on the current CPU. If WQ_PERCPU flag was not set, ci must be NULL. The enqueued work will be processed in a thread context. A work must not be enqueued again until the callback is called by the workqueue(9) frame- work.
SEE ALSO
intro(9), workqueue(9) NetBSD 5.0 August 8, 2007 NetBSD 5.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.