- NetBSD Manual Pages
WORKQUEUE(9) NetBSD Kernel Developer's Manual WORKQUEUE(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
workqueue -- simple do-it-in-thread-context framework
The workqueue utility routines are provided to defer work which is needed
to be processed in a thread context.
This section describes places within the NetBSD source tree where actual
code implementing the workqueue subsystem can be found. All pathnames
are relative to /usr/src.
The workqueue subsystem is implemented within the file
intro(9), workqueue_create(9), workqueue_destroy(9), workqueue_enqueue(9)
NetBSD 5.0 September 15, 2006 NetBSD 5.0