- NetBSD Manual Pages
BATTERY(4) NetBSD Kernel Interfaces Manual BATTERY(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
battery -- support for batteries and related functionality in Apple
Powerbook 2400, 3400 and 3500 (also known as Original PowerBook G3)
battery* at pmu?
The battery driver provides support for batteries and hardware sensors
found in 1st generation PCI-based PowerBooks, currently it only exports a
few sensors via the envsys(4) interface, including battery charge, volt-
age, CPU and battery temperature and AC power availability.
envsys(4), pmu(4), envstat(8)
There is no APM emulation right now and the battery current sensor may
return misleading or wrong data. This driver is considered preliminary
and may be replaced at some point.
NetBSD 5.0 April 2, 2008 NetBSD 5.0