atf(7) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
ATF(7)              NetBSD Miscellaneous Information Manual             ATF(7)


NAME
ATF -- introduction to the Automated Testing Framework
DESCRIPTION
The Automated Testing Framework (ATF) is a collection of libraries and utilities designed to ease unattended application testing in the hands of developers and end users of a specific piece of software. As regards developers, ATF provides the necessary means to easily create test suites composed of multiple test programs, which in turn are a col- lection of test cases. It also attempts to simplify the debugging of problems when these test cases detect an error by providing as much information as possible about the failure. As regards users, it simplifies the process of running the test suites and, in special, encourages end users to run them often: they do not need to have source trees around nor any other development tools installed to be able to certify that a given piece of software works on their machine as advertised. License ATF is distributed under the terms of the TNF License, a 4-clause BSD license. For more details please see: /usr/share/doc/atf/COPYING Components ATF is a highly modular piece of software. It provides a couple of libraries to ease the implementation of test programs: one for the C and C++ languages and another one for shell scripts. It also includes multi- ple small utilities that follow the principle of doing a single thing but doing it right. This section outlines which these components are. Public utilities: atf-compile(1) Generates an executable test program based on the description of test cases written in shell script- ing. atf-config(1) Queries static configuration information. atf-report(1) Converts the output of atf-run to user-friendly and/or machine-parseable reports. atf-run(1) Automates the execution of a series of test pro- grams and collects their results in a unified report. Internal utilities: atf-cleanup(1) Safely cleans up a work directory after a test case terminates. atf-exec(1) Executes a command after modifying its containing process. atf-format(1) Reformats a text string to not overflow terminal boundaries. atf-killpg(1) Sends a signal to a process group. Programming interfaces: atf-c++-api(3) C/C++ programming interface for test programs. atf-sh-api(3) POSIX shell programming interface for test pro- grams. Other: atf-formats(5) Description of the machine-parseable data formats used by the tools. atf-test-case(4) Generic description of test cases, independent of the language they are implemented in. atf-test-program(1) Common interface provided by the test programs written using the ATF libraries. Recommended reading order For end users wishing to run tests: 1. atf-test-program(1) 2. atf-run(1) 3. atf-report(1) 4. atf-config(1) For developers wanting to write their own tests: 1. Everything recommended to users. 2. atf-test-case(4) 3. atf-c++-api(3) 4. atf-sh-api(3) 5. atf-compile(1) For those interested in ATF internals: 1. Everything recommended to users. 2. Everything recommended to developers. 3. atf-formats(5) 4. atf-cleanup(1) 5. atf-format(1) 6. atf-exec(1) 7. atf-killpg(1)
HISTORY
ATF started as a Google Summer of Code 2007 project mentored by The NetBSD Foundation. Its original goal was to provide a testing framework for The NetBSD Operating System, but it grew as an independent project because the framework itself did not need to be tied to a specific oper- ating system. For more details on this subject, please see: /usr/share/doc/atf/NEWS /usr/share/doc/atf/ROADMAP
AUTHORS
For more details on the people that made ATF possible, please see: /usr/share/doc/atf/AUTHORS NetBSD 5.0 January 25, 2008 NetBSD 5.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.