microtime(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
MICROTIME(9)           NetBSD Kernel Developer's Manual           MICROTIME(9)


NAME
microtime -- realtime system clock
SYNOPSIS
#include <sys/time.h> void microtime(struct timeval *tv);
DESCRIPTION
microtime() returns the current value of the system realtime clock in the structure pointed to by the argument tv. The system realtime clock is guaranteed to be monotonically increasing at all times. As such, all calls to microtime() are guaranteed to return a system time greater than or equal to the system time returned in any previous calls.
SEE ALSO
settimeofday(2), hardclock(9), hz(9), inittodr(9), time(9)
CODE REFERENCES
The implementation of the microtime() function is machine dependent, hence its location in the source code tree varies from architecture to architecture.
BUGS
Despite the guarantee that the system realtime clock will always be mono- tonically increasing, it is always possible for the system clock to be manually reset by the system administrator to any date. NetBSD 4.0 September 14, 1998 NetBSD 4.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.