- NetBSD Manual Pages
HARDCLOCK(9) NetBSD Kernel Developer's Manual HARDCLOCK(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
hardclock -- real-time timer
hardclock(struct clockframe *);
The hardclock() function gets called hz(9) times per second. It performs
· Run the current process's virtual and profile time (decrease the cor-
responding timers, if they are activated, and generate SIGVTALRM or
· Increment the time-of-day, taking care of any ntpd(8) or adjtime(2)
induced changes and leap seconds, as well as any necessary compensa-
tions to keep in sync with PPS signals or external clocks, if support
for this is in the kernel (see options(4)).
· Schedule softclock interrupts if any callouts should be triggered
adjtime(2), ntp_adjtime(2), signal(7), ntpd(8), callout(9), hz(9)
NetBSD 4.0 September 5, 2001 NetBSD 4.0