systrace(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
SYSTRACE(4)             NetBSD Kernel Interfaces Manual            SYSTRACE(4)


NAME
systrace - enforce and generate policies for system calls
SYNOPSIS
options SYSTRACE
DESCRIPTION
The systrace kernel facility provides a mechanism to manipulate and enforce access policies for system calls. Using the systrace facility it is possible to monitor and control a process's access to the kernel through system calls. Access to the systrace facility is provided to userland processes, such as systrace(1), through an ioctl(2) interface on the pseudo-device /dev/systrace. This interface allows messages to be sent from the kernel to the userland process to request confirmation of an access policy. The systrace facility can assign the following policies to system calls for a specific process: SYSTR_POLICY_ASK Send a message on /dev/systrace requesting the access pol- icy for the system call. SYSTR_POLICY_PERMIT Immediately allow the system call. SYSTR_POLICY_NEVER Immediately deny the system call and return an error code.
SYSTRACE MESSAGES
A read(2) operation on the systrace pseudo-device will block if there are no pending messages, or return the following structure: struct str_message { int32_t msg_type; #define SYSTR_MSG_ASK 1 #define SYSTR_MSG_RES 2 #define SYSTR_MSG_EMUL 3 #define SYSTR_MSG_CHILD 4 pid_t msg_pid; int16_t msg_policy; union { struct str_msg_emul msg_emul; struct str_msg_ask msg_ask; struct str_msg_child msg_child; } msg_data; }; struct str_msg_emul { char emul[SYSTR_EMULEN]; }; struct str_msg_ask { int32_t code; int32_t argsize; register_t args[SYSTR_MAXARGS]; register_t rval[2]; int32_t result; }; struct str_msg_child { pid_t new_pid; };
IOCTL INTERFACE
The systrace facility supports the following ioctl(2) operations: STRIOCATTACH pid_t Attach to the process with the specified process ID. This opera- tion will fail under the following conditions: 1. The process is trying to attach to itself. 2. The process is a system process. 3. The process is being traced already. 4. You do not own the process and you are not root. 5. The process is init(8), and the kernel was not compiled with option INSECURE. STRIOCDETACH pid_t Wake up the process if it is waiting for an answer, and detach from it. STRIOCANSWER struct systrace_answer Notify the systrace facility in response to a SYSTR_MSG_ASK mes- sage what to do with a system call that was assigned a policy of SYSTR_POLICY_ASK. struct systrace_answer { pid_t stra_pid; /* PID of process being traced */ int32_t stra_policy; /* Policy to assign */ int32_t stra_error; /* Return value of denied syscall (will return EPERM if zero) */ int32_t stra_flags; #define SYSTR_FLAGS_RESULT 0x0001 /* Report syscall result */ }; Valid return values for stra_policy are SYSTR_POLICY_PERMIT, SYSTR_POLICY_ASK and SYSTR_POLICY_NEVER. STRIOCIO struct systrace_io Copy data in/out of the process being traced. struct systrace_io { pid_t strio_pid; /* PID of process being traced */ int32_t strio_ops; #define SYSTR_READ 1 #define SYSTR_WRITE 2 void *strio_offs; void *strio_addr; size_t strio_len; }; STRIOCPOLICY struct systrace_policy Manipulate the set of policies. struct systrace_policy { int strp_op; #define SYSTR_POLICY_NEW 1 /* Allocate a new policy */ #define SYSTR_POLICY_ASSIGN 2 /* Assign policy to process */ #define SYSTR_POLICY_MODIFY 3 /* Modify an entry */ int32_t strp_num; union { struct { int16_t code; #define SYSTR_POLICY_ASK 0 #define SYSTR_POLICY_PERMIT 1 #define SYSTR_POLICY_NEVER 2 int16_t policy; } assign; pid_t pid; int32_t maxents; } strp_data; #define strp_pid strp_data.pid #define strp_maxents strp_data.maxents #define strp_code strp_data.assign.code #define strp_policy strp_data.assign.policy }; The SYSTR_POLICY_NEW operation allocates a new policy with all entries initialized to SYSTR_POLICY_ASK, and returns the new pol- icy number into strp_num. The SYSTR_POLICY_ASSIGN operation attaches the policy identified by strp_num to strp_pid, with a maximum of strp_maxents entries. The SYSTR_POLICY_MODIFY opera- tion changes the entry indexed by strp_code to strp_policy. STRIOCGETCWD pid_t Set the working directory of the current process to that of the specified process. STRIOCRESCWD Restore the working directory of the current process.
FILES
/dev/systrace system call tracing facility
SEE ALSO
systrace(1), ioctl(2), read(2), options(4), init(8)
HISTORY
The systrace facility first appeared in OpenBSD 3.2, and then in NetBSD 2.0. NetBSD 2.0 July 14, 2003 NetBSD 2.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.