- NetBSD Manual Pages
AMIDISPLAYCC(4) NetBSD/amiga Kernel Interfaces Manual AMIDISPLAYCC(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
amidisplaycc -- wscons interface to amiga custom chips drivers
amidisplaycc0 at mainbus0
wsdisplay0 at amidisplaycc0
This device acts as an adapter between the wscons(4) framework and the
Amiga custom chip driver functions. It exports the internal wsdisplay(4)
interface and contains the necessary rendering functions to operate a
text terminal with virtual screens. It uses the Amiga abstract graphic
driver (grfabs) functions for the low-level display management.
Currently it does not support running X. It can however coexist well
enough with grf0 to make possible running X the old way, but be warned,
you cannot switch screens while in X and when quitting it, it seems to
hang. Switching a screen then will bring up the text console.
It supports foreground and background color, and the hilite (bold),
underline, and reverse text attributes.
Virtual terminals and screen types
The number of virtual screens is limited only by the available chip mem-
Each virtual screen can have a different screen type. A screen type
defines the following things: height and width in pixels, number of col-
ors, and font size. The supported screen types are listed below.
· 80x64 - display size 640x512 with 8 colors, font size 8x8
· 80x51 - display size 640x510 with 8 colors, font size 8x10
· 80x50 - display size 640x400 with 8 colors, font size 8x8
· 80x40 - display size 640x400 with 8 colors, font size 8x10
· 80x32 - display size 640x512 with 8 colors, font size 8x16
· 80x31 - display size 640x248 with 8 colors, font size 8x8
· 80x25 - display size 640x400 with 8 colors, font size 8x16
· 80x24 - display size 640x192 with 8 colors, font size 8x8
· default - same as either 80x64 or 80x50, depending on the pres-
ence of GRF_NTSC and GRF_PAL in the kernel configuration.
The grfabs code determines the actual screen mode that is used. The con-
fig options GRF_NTSC, GRF_PAL, GRF_AGA, etc. determine what kind of
chipsets/modes are available.
Fonts of width 8 and any height are supported. Fonts can be compiled
into the kernel by specifying "options FONT_[fontname]" in the configura-
tion file, or loaded with the wsfontload(8) utility runtime.
wscons(4), wsdisplay(4), wsfontload(8), wsfont(9)
NetBSD 9.99 November 12, 2003 NetBSD 9.99