- NetBSD Manual Pages
ACPIWMI(4) NetBSD Kernel Interfaces Manual ACPIWMI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
acpiwmi -- Windows Management Instrumentation support for ACPI
acpiwmi* at acpi?
wmidell* at acpiwmibus?
wmieeepc* at acpiwmibus?
wmihp* at acpiwmibus?
wmimsi* at acpiwmibus?
The acpiwmi device driver provides an ACPI interface for Windows Manage-
ment Instrumentation (WMI). The ACPI WMI interface is typically used to
support vendor specific features found in various laptops.
The following WMI mappings are supported:
wmidell Dell laptops
wmieeepc Some models of Asus Eee PC
wmihp Hewlett-Packard laptops
wmimsi MSI laptops
The functionality varies from vendor to vendor. Typically the interface
is used for function and hotkey handling, but additional features may be
Microsoft Corporation, Windows Instrumentation: WMI and ACPI,
The acpiwmi device driver appeared in NetBSD 6.0.
Jukka Ruohonen <email@example.com> wrote acpiwmi and most of the mappings.
While WMI should provide a certain degree of portability across laptop
models from a particular vendor, there is no guarantee that the mappings
are functional in all models.
The wmihp driver may conflict with hpqlb(4).
NetBSD 10.99 May 27, 2019 NetBSD 10.99