options(4) - NetBSD Manual Pages

OPTIONS(4)                NetBSD Programmer's Manual                OPTIONS(4)


NAME
options - Miscellaneous kernel configuration options
SYNOPSIS
options ...
DESCRIPTION
This manual page describes a number of miscellaneous kernel configuration options that may be specified in a kernel config file. See config(8) for information on how to configure and build kernels. Note: Options are passed to the compile process as -D flags to the C compiler. Compatibility Options options COMPAT_09 Enable binary compatibility with NetBSD 0.9. This enables support for 16-bit user, group, and process ids (following revisions support 32-bit identifiers), It also allows the use of the deprecated getdomainname, setdomainname, and uname syscalls. This option also allows using numeric filesystem identifiers rather than strings. Post 0.9 versions use string identifiers. options COMPAT_10 Enable binary compatibility with NetBSD 1.0. This option allows the use of the filesystem name of ``ufs'' as an alias for ``ffs''. The name ``ffs'' should be used post 1.0 in /etc/fstab and other files. It also adds old syscalls for the AT&T System V UNIX shared memory interface. This was changed post 1.0 to work on 64-bit architectures. This option also enables ``sgtty'' compatibility, without which programs using the old interface produce an ``inappropriate ioctl'' error. options COMPAT_11 Enable binary compatibility with NetBSD 1.1. This allows binaries run- ning on the i386 port to gain direct access to the io ports by opening /dev/io read/write. This functionality was replaced by i386_iopl(2) post 1.1. On the Atari port, the location of the disk label was moved after 1.1. When the COMPAT_11 option is set, the kernel will read (pre) 1.1 style disk labels as a last resort. When a disklabel is re-written, the old style label will be replaced with a post 1.1 style label. options COMPAT_12 Enable binary compatibility with NetBSD 1.2. This allows the use of old syscalls for reboot() and swapon(). The syscall numbers were changed post 1.2 to add functionality to the reboot syscall, and the new swapctl() interface was introduced. options COMPAT_43 Enables compatibility with 4.3BSD. This adds an old syscall for lseek. It also adds the ioctls for TIOCGETP and TIOCSETP. The return values for getpid, getgid, and getuid syscalls are modified as well, to return the parent's pid and uid as well as the current process's. It also enables the deprecated NTTYDISC terminal line discipline. It also provides back- wards compatibility with ``old'' SIOC[GS]IF{ADDR,DSTADDR,BRDADDR,NETMASK} interface ioctls, including binary compatibility with code written before the introduction of the sa_len field in sockaddrs. It also enables sup- port for some older pre BSD 4.4 socket calls. options COMPAT_SVR4 On those architectures that support it, this enables binary compatibility with AT&T System V.4 UNIX applications built for the same architecture. This currently includes the sparc and i386. options COMPAT_LINUX On those architectures that support it, this enables binary compatibility with Linux ELF and a.out applications built for the same architecture. This is currently limited to the i386. options COMPAT_SUNOS On those architectures that support it, this enables binary compatibility with SunOS 4.1 applications built for the same architecture. This cur- rently includes the sparc and most or all m68k platforms. options COMPAT_ULTRIX On those architectures that support it, this enables binary compatibility with Ultrix applications built for the same architecture. This currently is limited to the pmax. The functionality of this option is unknown. options COMPAT_FREEBSD On those architectures that support it, this enables binary compatibility with FreeBSD applications built for the same architecture. This is obvi- ously limited to the i386. options COMPAT_HPUX On those architectures that support it, this enables binary compatibility with HP/UX applications built for the same architecture. This is limited to the hp300 port, and has some known bugs. A limited set of programs do work. options COMPAT_IBCS2 On those architectures that support it, this enables binary compatibility with iBCS2 applications built for the same architecture. This is cur- rently limited to the i386. options COMPAT_OSF1 On those architectures that support it, this enables binary compatibility with Digital UNIX (formerly OSF/1) applications built for the same archi- tecture. This is currently limited to the alpha, and may not even work. options COMPAT_NOMID Enable compatibility with a.out executables that lack a machine id. This includes NetBSD 0.8's ZMAGIC format, and 386BSD and BSDI's QMAGIC, NMAG- IC, and OMAGIC a.out formats. Debugging Options options DDB Compiles in a kernel debugger for diagnosing kernel problems. See ddb(4) for details. NOTE: not available on all architectures. options DDB_HISTORY_SIZE=integer If this is non-zero, enable history editing in the kernel debugger and set the size of the history to this value. options DDB_ONPANIC If set to non-zero, the DDB will be entered upon kernel panic. The de- fault if not specified is "1". Note that this sets the value of the ddb.onpanic sysctl variable which may be changed at run time -- see sysctl(8) for details. options KGDB Compiles in a remote kernel debugger stub for diagnosing kernel problems using the ``remote target'' feature of gdb. See gdb(1) for details. NOTE: not available on all architectures. makeoptions DEBUG="-g" The -g flag causes netbsd.gdb to be built in addition to netbsd. netbsd.gdb is useful for debugging kernel crash dumps with gdb. The com- mand gdb -k invokes gdb in kernel debugger mode. See gdb(1) for details. This also turns on options DEBUG (which see). options DEBUG Turns on miscellaneous kernel debugging. Since options are turned into preprocessor defines (see above), options DEBUG is equivalent to doing a #define DEBUG throughout the kernel. Much of the kernel has #ifdef DEBUG conditionalized debugging code. Note that many parts of the kernel (typi- cally device drivers) include their own #ifdef XXX_DEBUG conditionals in- stead. This option also turns on certain other options, which may de- crease system performance. options DIAGNOSTIC Adds code to the kernel that does internal consistency checks. This code will cause the kernel to panic if corruption of internal data structures is detected. options KTRACE Add hooks for the system call tracing facility, which allows users to watch the system call invocation behavior of processes. See ktrace(1) for details. options MSGBUFSIZE=integer This option sets the size of the kernel message buffer. This buffer holds the kernel output of printf() when not (yet) read by syslogd(8). This is particularly useful when the system has crashed and you wish to lookup the kernel output from just before the crash. Also, since the autoconfig output becomes more and more verbose, it sometimes happens that the mes- sage buffer overflows before syslogd(8) was able to read it. Note that not all systems are capable of obtaining a variable sized message buffer. There are also some systems on which memory contents are not preserved accross reboots. File Systems file-system FFS Includes code implementing the Berkeley Fast File System (FFS). Most ma- chines need this if they are not running diskless. file-system EXT2FS Includes code implementing the Second Extended File System (EXT2FS). This is the most commonly used file system on the Linux operating system, and is provided here for compatibility. Some of the specific features of EXT2FS like the "behavior on errors" are not implemented. This file sys- tem can't be used with UID or GID greater than 65535. See mount_ext2fs(8) for details. file-system LFS Include the log structured file system (LFS). See mount_lfs(8) and newlfs(8) for details. file-system MFS Include the memory file system (MFS). This file system stores files in swappable memory, and produces notable performance improvements when it is used as the file store for /tmp and similar file systems. See mount_mfs(8) for details. file-system NFS Include the client side of the NFS (Network File System) remote file sharing protocol. Although the bulk of the code implementing NFS is ker- nel based, several user level daemons are needed for it to work. See mount_nfs(8) and nfsiod(8) for details. file-system CD9660 Includes code for the ISO 9660 + Rock Ridge file system, which is the standard file system on many CD-ROMs. Useful mostly if you have a CD drive. See mount_cd9660(8) for details. file-system MSDOSFS Includes the MS-DOS FAT file system, which is reportedly still used by unfortunate people who have not heard about NetBSD. Also implements the Windows 95 extensions to the same, which permit the use of longer, mixed case file names. see mount_msdos(8) and fsck_msdos(8) for details. file-system FDESC Includes code for a file system, conventionally mounted on /dev/fd, which permits access to the per-process file descriptor space via special files in the file system. See mount_fdesc(8) for details. Note that this fa- cility is redundant, and thus unneeded on most NetBSD systems, since the fd(4) pseudodevice driver already provides identical functionality. On most NetBSD systems, instances of fd(4) are mknoded under /dev/fd/ and on /dev/stdin, /dev/stdout, and /dev/stderr. file-system KERNFS Includes code which permits the mounting of a special file system (nor- mally mounted on /kern) in which files representing various kernel vari- ables and parameters may be found. See mount_kernfs(8) for details. file-system NULLFS Includes code for a loopback file system. This permits portions of the file hierarchy to be re-mounted in other places. The code really exists to provide an example of a stackable file system layer. See mount_null(8) for details. file-system PORTAL Includes the (experimental) portal filesystem. This permits interesting tricks like opening TCP sockets by opening files in the file system. The portal file system is conventionally mounted on /p and is partially im- plemented by a special daemon. See mount_portal(8) for details. file-system PROCFS Includes code for a special file system (conventionally mounted on /proc) in which the process space becomes visible in the file system. Among oth- er things, the memory spaces of processes running on the system are visi- ble as files, and signals may be sent to processes by writing to ctl files in the procfs namespace. See mount_procfs(8) for details. file-system UMAPFS Includes a loopback file system in which user and group ids may be remapped -- this can be useful when mounting alien file systems with dif- ferent uids and gids than the local system. See mount_umap(8) for de- tails. file-system UNION Includes code for the union file system, which permits directories to be mounted on top of each other in such a way that both file systems remain visible -- this permits tricks like allowing writing (and the deleting of files) on a read-only file system like a CD-ROM by mounting a local writable file system on top of the read-only file system. See mount_union(8) for details. File System Options options NFSSERVER Include the server side of the NFS (Network File System) remote file sharing protocol. Although the bulk of the code implementing NFS is ker- nel based, several user level daemons are needed for it to work. See mountd(8) and nfsd(8) for details. options QUOTA Enables kernel support for file system quotas. See quotaon(8), edquota(8), and quota(1) for details. Note that quotas only work on ``ffs'' file systems, although rpc.rquotad(8) permits them to be accessed over NFS. options FIFO Augments the system to permit the use of AT&T System V UNIX style FIFOs (i.e. ``named pipes'' ). This option is recommended. options NVNODE=integer This option sets the size of the cache used by the name-to-inode transla- tion routines, (a.k.a. the namei() cache, though called by many other names in the kernel source). By default, this cache has NPROC (set as 20 + 16 * MAXUSERS) * (80 + NPROC / 8) entries. A reasonable way to derive a value of NVNODE, should you notice a large number of namei cache misses with a tool such as systat(1), is to examine your system's current com- puted value with sysctl(1), (which calls this parameter "kern.maxvn- odes") and to increase this value until either the namei cache hit rate improves or it is determined that your system does not benefit substan- tially from an increase in the size of the namei cache. options EXT2FS_SYSTEM_FLAGS This option changes the behavior of the APPEND and IMMUTABLE flags for a file on an EXT2FS filesystem. Without this option, the superuser or owner of the file can set and clear them. With this option, only the superuser can set them, and they can't be cleared if the securelevel is greater than 0. See also chflags(1). Miscellaneous Options options LKM Enable loadable kernel modules. See lkm(4) for details. NOTE: not avail- able on all architectures. options INSECURE Hardwires the kernel security level at -1. This means that the system al- ways runs in secure level 0 mode, even when running multiuser. See the manual page for init(8) for details on the implications of this. The ker- nel secure level may manipulated by the superuser by altering the kern.securelevel sysctl variable. (It should be noted that the secure level may only be lowered by a call from process id 1, i.e. init.) See also sysctl(8) and sysctl(3). options UCONSOLE Normally, only the superuser can execute the TIOCCONS ioctl, which redi- rects console output to a non-console tty. (See tty(4) for details). This option permits any user to execute the ioctl. This is useful on ma- chines such as personal workstations which run X servers, where one would prefer to permit console output to be viewed in a window without requir- ing a suid root program to do it. options MACHINE_NONCONTIG This option changes part of the VM/pmap interface, to allow for non-con- tiguous memory. On some ports it is not an option. These ports typical- ly only use one of the interfaces. options MEMORY_DISK_HOOKS This option allows for some machine dependent functions to be called when the ramdisk driver is configured. This can result in automatically load- ing a ramdisk from floppy on open (among other things). options MEMORY_DISK_IS_ROOT Forces the ramdisk to be the root device. This can only be overridden when the kernel is booted in the 'ask-for-root' mode. options NTP Turns on in-kernel precision timekeeping support used by software imple- menting NTP (Network Time Protocol, RFC1305). The NTP option adds an in- kernel phase-locked loop (PLL) for normal NTP operation, and a frequency- locked loop (FLL) for intermittently-connected operation. xntpd(8) will employ a user-level PLL when kernel support is unavailable, but the in- kernel version has lower latency and more precision, and so typically keeps much better time. The interface to the kernel NTP support is pro- vided by the ntp_adjtime(2) and ntp_gettime(2) system calls, which are intended for use by xntpd(8) and are enabled by the option. On systems with sub-microsecond resolution timers, or where (HZ / 100000) is not an integer, the NTP option also enables extended-precision arithmetic to keep track of fractional clock ticks at NTP time-format precision. options PPS_SYNC This option enables a kernel serial line discipline for receiving time phase signals from an external reference clock such as a radio clock. (The NTP option (which see) must be on if the PPS_SYNC option is used.) Some reference clocks generate a pulse per second (PPS) signal in phase with their time source. The PPS line discipline receives this signal on either the data leads or the DCD control lead of a serial port. NTP uses the PPS signal to discipline the local clock oscillator to a high degree of precision (typically less than 50 microseconds in time and 0.1 ppm in accuracy). PPS can also generate a serial output pulse when the system receives a PPS interrupt. This can be used to measure the system inter- rupt latency and thus calibrate NTP to account for it. Using PPS usually requires a gadget box to convert from TTL to RS-232 signal levels. The gadget box and PPS are described in more detail in the HTML documentation shipped with the xntpd distribution. option SETUIDSCRIPTS Allows scripts with the setuid bit set to execute as the effective user rather than the real user, just like binary executables. NOTE: Using this option will also enable option FDSCRIPTS option FDSCRIPTS Allows execution of scripts with the execute bit set, but not the read bit, by opening the file and passing the file descriptor to the shell, rather than the filename. NOTE: Execute only (non-readable) scripts will have argv[0] set to /dev/fd/*. What this option allows as far as security is concerned, is the ability to safely ensure that the correct script is run by the interpreter, as it is passed as an already open file. options RTC_OFFSET=integer The kernel (and typically the hardware battery backed-up clock on those machines that have one) keeps time in UTC (Universal Coordinated Time, once known as GMT, or Greenwich Mean Time) and not in the time of the lo- cal time zone. The RTC_OFFSET option is used on some ports (such as the i386) to tell the kernel that the hardware clock is offset from UTC by the specified number of minutes. This is typically used when a machine boots several operating systems and one of them wants the hardware clock to run in the local time zone and not in UTC, e.g. RTC_OFFSET=300 means the hardware clock is set to US Eastern Time (300 minutes behind UTC), and not UTC. (Note: RTC_OFFSET is used to initialize a kernel variable named rtc_offset which is the source actually used to determine the clock offset, and which may be accessed via the kern.rtc_offset sysctl vari- able. See sysctl(8) and sysctl(3) for details. Since the kernel clock is initialized from the hardware clock very early in the boot process, it is not possible to meaningfully change rtc_offset in system initialization scripts. Changing this value currently may only be done at kernel com- pile time or by patching the kernel and rebooting.) options CCDNBUF=integer The ccd(4) device driver uses "component buffers" to distribute I/O re- quests to the components of a concatenated disk. It keeps a freelist of buffer headers in order to reduce use of the kernel memory allocator. CCDNBUF is the number of buffer headers allocated on the freelist for each component buffer. It defaults to 8. options KMEMSTATS The kernel memory allocator, malloc(9), will keep statistics on its per- formance if this option is enabled. Unfortunately, this option therefore essentially disables the MALLOC() and FREE() forms of the memory alloca- tor, which are used to enhance the performance of certain critical sec- tions of code in the kernel. This option therefore can lead to a signif- icant decrease in the performance of certain code in the kernel if en- abled. Examples of such code include the namei() routine, the ccd(4) driver, the ncr(4) driver, and much of the networking code. options MAXUPRC=integer Sets the RLIMIT_NPROC resource limit, which specifies the maximum number of simultaneous processes a user is permitted to run, for process 0; this value is inherited by its child processes. It defaults to CHILD_MAX, which is currently defined to be 80. Setting MAXUPRC to a value less than CHILD_MAX is not permitted, as this would result in a violation of the semantics of IEEE Std1003.1-1990 (``POSIX''). Networking Options options GATEWAY Enables IPFORWARDING (which see) and (on most ports) increases the size of NMBCLUSTERS (which see). In general, GATEWAY is used to indicate that a system should act as a router, and IPFORWARDING is not invoked direct- ly. (Note that GATEWAY has no impact on protocols other than IP, such as CLNP or XNS.) options IPFORWARDING Enables IP routing behavior. With this option enabled, the machine will forward IP datagrams between its interfaces that are destined for other machines. Note that even without this option, the kernel will still for- ward some packets (such as source routed packets) -- removing GATEWAY and IPFORWARDING is insufficient to stop all routing through a bastion host on a firewall -- source routing is controlled independently. To turn off source routing, use options IPFORWSRCRT=0 (which see). Note that IP for- warding may be turned on and off independently of the setting of the IPFORWARDING option through the use of the net.inet.ip.forwarding sysctl variable. If net.inet.ip.forwarding is 1, IP forwarding is on. See sysctl(8) and sysctl(3) for details. options IPFORWSRCRT=value If value is set to zero, source routing of IP datagrams is turned off. If value is set to one (the default) or the option is absent, source routed IP datagrams are forwarded by the machine. Note that source routing of IP packets may be turned on and off independently of the setting of the IPFORWSRCRT option through the use of the net.inet.ip.forwsrcrt sysctl variable. If net.inet.ip.forwsrcrt is 1, forwarding of source routed IP datagrams is on. See sysctl(8) and sysctl(3) for details. options MROUTING Includes support for IP multicast routers. You certainly want INET with this. Multicast routing is controlled by the mrouted(8) daemon. options INET Includes support for the TCP/IP protocol stack. You almost certainly want this. See inet(4) for details. This option is currently required. options MCLSHIFT=value This option is the base-2 logarithm of the size of mbuf clusters. The BSD networking stack keeps network packets in a linked list, or chain, of kernel buffer objects called mbufs. The system provides larger mbuf clusters as an optimization for large packets, instead of using long chains for large packets. The mbuf cluster size, or MCLBYTES, must be a power of two, and is computed as two raised to the power MCLSHIFT. On systems with Ethernet network adaptors, MCLSHIFT is often set to 11, giv- ing 2048-byte mbuf clusters, large enough to hold a 1500-byte Ethernet frame in a single cluster. Systems with networks supporting larger frame sizes like ATM, FDDI, or HIPPI may perform better with MCLSHIFT set to 12 or 13, giving mbuf cluster sizes of 4096 and 8192 bytes, respectively. options NS Include support for the Xerox XNS protocol stack. See ns(4) for details. options ISO,TPIP Include support for the ubiquitous OSI protocol stack. See iso(4) for de- tails. options EON Include support for OSI tunneling over IP. options CCITT,LLC,HDLC Include support for the X.25 protocol stack. The state of this code is currently unknown, and probably contains bugs. options NETATALK Include support for the Appletalk protocol stack. The kernel provides provision for the Datagram Delivery Protocol (DDP), providing SOCK_DGRAM support and Appletalk routing. This stack is used by the Netatalk pack- age, which adds support for Appletalk server services via user libraries and applications. options IPNOPRIVPORTS Normally, only root can bind a socket descriptor to a so-called ``privileged'' TCP port, that is, a port number in the range 0-1023. This option eliminates those checks from the kernel. This can be useful if there is a desire to allow daemons without privileges to bind those ports, e.g. on firewalls. The security tradeoffs in doing this are sub- tle. This option should only be used by experts. options TCP_COMPAT_42 TCP bug compatibility with 4.2BSD. In 4.2BSD, TCP sequence numbers were 32-bit signed values. Modern implementations of TCP use unsigned values. This option clamps the initial sequence number to start in the range 2^31 rather than the full unsigned range of 2^32. Also, under 4.2BSD, keepalive packets must contain at least one byte or else the remote end would not respond. options PFIL_HOOKS This option turns on the packet filter interface hooks. See pfil(9) for details. options IPFILTER_LOG This option, in conjunction with pseudo-device ipfilter, enables logging of IP packets using ip-filter. options IPFILTER_DEFAULT_BLOCK This option sets the default policy of ip-filter. If it is set, ip-fil- ter will block packets by default. options PPP_FILTER This option turns on pcap(3) based filtering for ppp connections. This option is used by pppd(8) which needs to be compiled with PPP_FILTER de- fined (the current default). System V IPC Options options SYSVMSG Includes support for AT&T System V UNIX style message queues. See msgctl(2), msgget(2), msgrcv(2), msgsnd(2). options SYSVSEM Includes support for AT&T System V UNIX style semaphores. See semctl(2), semget(2), semop(2). options SYSVSHM Includes support for AT&T System V UNIX style shared memory. See shmat(2), shmctl(2), shmdt(2), shmget(2). options SHMMAXPGS=value Sets the maximum number of AT&T System V UNIX style shared memory pages that are available through the shmget(2) system call. Default value is 1024 on most ports. See /usr/include/machine/vmparam.h for the default. VM Related Options options SWAPPAGER Turns on paging. (To be specific, this enables the virtual memory module responsible for handling page faults for ``anonymous'' objects (i.e. BSS pages)). MANDATORY -- you cannot actually run without this ``option''. options VNODEPAGER Support for mmap()ing of files. (Specifically, this enables the virtual memory module responsible for handling page faults on mapped files ( ``plain file'' vnodes)). MANDATORY -- you cannot actually run without this ``option''. options DEVPAGER Support for mmap()ing of devices. (Specifically, this enables the virtu- al memory module responsible for handling page faults on mapped devices ( ``cdev'' vnodes)). MANDATORY -- you cannot actually run without this ``option''. options NMBCLUSTERS=value Size of kernel mbuf cluster map, mb_map, in CLBYTES-sized logical pages. Default on most ports is 256 (512 with ``options GATEWAY ).'' See /usr/include/machine/param.h for exact default information. Increase this value if you get ``mb_map full'' messages. options NKMEMCLUSTERS=value Size of kernel malloc arena in CLBYTES-sized logical pages. This area is covered by the kernel submap kmem_map. See /usr/include/machine/param.h for the default value, which is port specific. Increase this value if you get ``out of space in kmem_map'' panics. options NBUF=value options BUFPAGES=value These option set the number of pages available for the buffer cache. Their default value is a machine dependent value, often calculated as be- tween 5% and 10% of total available RAM. amiga-specific Options options LIMITMEM=value If there, limit the part of the first memory bank used by NetBSD to value megabytes. Default is unlimited. options NKPTADD=addvalue options NKPTADDSHIFT=shiftvalue The cpu specific MMU table for the kernel is pre-allocated at kernel startup time. Part of it is scaled with maxproc, to have enough room to hold the user program MMU tables; the second part is a fixed amount for the kernel itself. The third part accounts for the size of the file buffer cache. Its size is either NKPTADD pages (if defined) or memorysize in bytes divided by two to the power of NKPTADDSHIFT. The default is undefined NKPTADD and NKPTADDSHIFT=24, allowing for 16 buffers per megabyte of main memory (while a GENERIC kernel allocates about half of that). When you get "can't get KPT page" panics, you should increase NKPTADD (if defined), or decrease NKPTADDSHIFT by one. atari-specific Options options DISKLABEL_AHDI Include support for AHDI (native Atari) disklabels. options DISKLABEL_NBDA Include support for NetBSD-atari labels. If you don't set this option, it will be set automatically. NetBSD/atari will not work without it. options FALCON_SCSI Include support for the 5380-SCSI configuration as found on the Falcon. options RELOC_KERNEL If set, the kernel will relocate itself to TT-ram, if possible. This will give you a slightly faster system. Bewarned that on some TT030 systems, the system will frequently dump with MMU-faults with this option enabled. options SERCONSOLE Allow the modem1-port to act as the system-console. A carier should be active on modem1 during system boot to active the console functionality. options TT_SCSI Include support for the 5380-SCSI configuration as found on the TT030 and Hades. i386-specific Options options I386_CPU,I486_CPU,I586_CPU,I686_CPU Include support for a particular class of CPU (i386, i486, Pentium, or Pentium Pro). If the appropriate class for your CPU is not configured, the kernel will use the highest class available that will work. In gen- eral, using the correct CPU class will result in the best performance. At least one of these options must be present. options MATH_EMULATE Include the floating point emulator. This is useful only for CPUs that lack an internal floating point unit or coprocessor. options VM86 Include support for virtual 8086 mode, used by DOS emulators. options USER_LDT Include i386-specific system calls for modifying the local descriptor table, used by Windows emulators. options REALBASEMEM Overrides the base memory size passed in from the boot block. Use this option only if the boot block reports the size incorrectly. (Note that some BIOSes put the extended BIOS data area at the top of base memory, and therefore report a smaller base memory size to prevent programs over- writing it. This is correct behavior, and you should not use the REALBASEMEM option to access this memory.) options REALEXTMEM Overrides the extended memory size passed in from the boot block. Use this option only if the boot block reports the size incorrectly. options FRENCH_KBD,GERMAN_KBD,NORVEGIAN_KBD Select a non-US keyboard layout for the pccons console driver. m68k-specific Options options FPU_EMULATE Include support for MC68881/MC68882 emulator. options FPSP Include support for 68040 floating point. options M68030,M68040,M68060 Include support for a specific cpu, at least one (the one you are using) should be specified. options M060SP Include support for 68060 floating point.
SEE ALSO
config(8), init(8), gettimeofday(2), sysctl(8), sysctl(3), xntpd(8), ntp_adjtime(2), ntp_gettime(2), i386_iopl(2), msgctl(2), msgget(2), msgrcv(2), msgsnd(2), semctl(2), semget(2), semop(2), shmat(2), shmctl(2), shmdt(2), shmget(2), ddb(4), lkm(4), inet(4), ns(4), iso(4), mrouted(8), mount_lfs(8), newlfs(8), mount_mfs(8), mount_nfs(8), mount_cd9660(8), mount_msdos(8), mount_fdesc(8), mount_kernfs(8), mount_null(8), mount_portal(8), mount_procfs(8), mount_umap(8), mount_union(8), edquota(8), quotaon(8), quota(1), rpc.rquotad(8), ktrace(1), gdb(1)
HISTORY
The options man page first appeared in NetBSD 1.3.
BUGS
The INET and the VNODEPAGER options should not be required. NetBSD 1.3 October 20, 1996 11

Powered by man-cgi (2024-08-26). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.