CCD(4) NetBSD Programmer's Manual CCD(4)
NAME
ccd - Concatenated Disk Driver
SYNOPSIS
pseudo-device ccd [count]
DESCRIPTION
The ccd driver provides the capability of combining one or more disks/partitions into one virtual disk. This document assumes that you're familiar with how to generate kernels, how to properly configure disks and pseudo-devices in a kernel configura- tion file, and how to partition disks. Note that the `raw' partitions of the disks should not be combined. Each component partition should be offset at least one cylinder from the be- ginning of the component disk. This avoids potential conflicts between the component disk's disklabel and the ccd's disklabel. The kernel will only allow component partitions of type FS_BSDFFS. In order to compile in support for the ccd, you must add a line similar to the following to your kernel configuration file: pseudo-device ccd 4 # concatenated disk devices The count argument is how many ccds memory is allocated for at boot time. In this example, no more than 4 ccds may be configured. A ccd may be either serially concatenated or interleaved. If a ccd is interleaved correctly, a ``striping'' effect is achieved, which can in- crease performance. The optimum interleave factor is typically the size of a track. Since the interleave factor is expressed in units of DEV_BSIZE, one must account for sector sizes other than DEV_BSIZE in or- der to calculate the correct interleave. The kernel will not allow an interleave factor less than the size of the largest component sector di- vided by DEV_BSIZE. Note that best performance is achieved if all component disks have the same geometry and size. Optimum striping cannot occur with different disk types. The ccd also supports primitive data mirroring. To enable this mirroring support, the ccd must be configured with the CCDF_MIRROR flag set. Note that the CCDF_MIRROR flag implies the CCDF_UNIFORM flag and requires an interleaved even number of components. Mirroring functions by making the second n/2 components exact duplicates of the first n/2. For example, in a mirrored ccd with components sd0g, sd1g, sd2g, and sd3g, sd2g would mirror sd0g and sd3g would mirror sd1g. Reads will come from the first n/2 components (in this example: sd0g and sd1g) while writes will go to all components. If a component of a mirrored ccd should fail, the ccd can be reconfigured as a non-mirrored ccd until the failed component can be replaced. For example, using the hypothetical ccd above, the recovery process might look like this: * Component sd1g fails. Reconfigure ccd without mirroring using the same interleave factor with components sd0g and sd3g. ccd can still be used until replacement drive arrives. * Replace failed component. Using dd(1), copy the contents of sd3g to the new sd1g. * Restore ccd configuration to that of before the component failure. There is a run-time utility that is used for configuring ccds. See ccdconfig(8) for more information.
WARNINGS
If just one (or more) of the disks in a non-mirrored ccd fails, the en- tire file system will be lost.
FILES
/dev/{,r}ccd* ccd device special files.
HISTORY
The concatenated disk driver was originally written at the University of Utah.
SEE ALSO
MAKEDEV(8), ccdconfig(8), config(8), fsck(8), mount(8), newfs(8). NetBSD August 9, 1995 2
Powered by man-cgi (2024-08-26). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.