- NetBSD Manual Pages
TCO(4) NetBSD/x86 Kernel Interfaces Manual TCO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
tco -- Intel Controller Hub TCO watchdog timer device
tco* at ichlpcib?
The tco driver provides support for the watchdog timer included in the
Intel Controller Hub (ICH).
Setting the timer interval and arming the watchdog is performed using the
wdogctl(8) utility. For ICH5 and earlier controllers, the interval is in
the range of 2 to 23 seconds; for ICH6 and newer controllers, the inter-
val is in the range of 1 to 367 seconds.
The tco driver first appeared in NetBSD 8.0. In earlier releases of
NetBSD the driver was included as part of the x86/ichlpcib(4) driver.
The tco driver was written by Minoura Makoto <minoura@NetBSD.org> and
Matthew R. Green <mrg@NetBSD.org>. The tco driver was separated from the
x86/ichlpcib(4) driver by Paul Goyette <pgoyette@NetBSD.org>.
NetBSD 9.99 April 4, 2015 NetBSD 9.99