- NetBSD Manual Pages
ISP(4) NetBSD Kernel Interfaces Manual ISP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
isp -- Qlogic based SCSI and FibreChannel SCSI Host Adapters
isp* at pci? dev? function? (PCI)
isp* at sbus? slot ? offset ? (SBus)
scsibus* at isp?
This driver provides access to SCSI or FibreChannel devices.
SCSI features include support for Ultra SCSI and wide mode transactions
for SCSI, and LVD (for the ISP1080 and ISP1280),
Fibre Channel support uses FCP SCSI profile for FibreChannel and uses
Class 3 connections only. Support is available for Public and Private
loops. Command tagging is supported for all (in fact, FibreChannel
An optional flags 0x80 appended to the above isp declarations will dis-
able the download of driver firmware, which means you use whatever
firmware is running on the card. If no firmware is running on the card,
the driver cannot operate the card.
An optional flags 0x40 appended to the above isp declarations (can be
OR'd in with the other config flags option) will keep the driver from
looking at device or bus NVRAM settings (this is in case NVRAM is just
wrong and you have the card in a platform where it is inconvenient to
change NVRAM settings on the card).
Supported cards include:
SBus Fast Wide, Ultra Fast Wide cards, Single Ended or Dif-
Performance Technology ISP1000 variants.
Qlogic 1020 Fast Wide and Differential Fast Wide PCI cards.
Qlogic 1040 Ultra Wide and Differential Ultra Wide PCI
Performance Technology ISP1040 variants.
Qlogic 1240 Dual Bus Ultra Wide and Differential Ultra Wide
Qlogic 1280 LVD Ultra2 Wide PCI cards.
Qlogic 1280 Dual Bus LVD Ultra2 Wide PCI cards.
Qlogic 2100 and 2100A Copper and Optical Fibre Channel
Qlogic Dual Loop 2100A Optical Fibre Channel Arbitrated
Loop PCI cards.
Qlogic 2200 Copper and Optical Fibre Channel Arbitrated
Loop PCI cards.
Qlogic 2200 Dual Bus Optical Fibre Channel Arbitrated Loop
Qlogic 2200 Quad Bus Optical Fibre Channel Arbitrated Loop
Qlogic 2300 2-Gigabit Optical Fibre Channel PCI cards.
Qlogic 2300 2-Gigabit Dual Channel Optical Fibre Channel
Performance Technology ISP2100 variants.
Antares Microsystems ISP2100 variants.
Qlogic 2400 4-Gigabit Optical Fibre Channel PCI cards.
Qlogic 2500 8-Gigabit Optical Fibre Channel PCI cards.
cd(4), intro(4), scsi(4), sd(4), st(4)
The isp driver was written by Matthew Jacob for NASA/Ames Research Cen-
The driver currently ignores some NVRAM settings.
The driver currently doesn't do error recovery for timed out commands
Sometimes, when booting, the driver gets stuck waiting for the Fibre
Channel firmware to tell it that the loop port database is ready. In
this case you'll see an announcement that the loop state has a value of
0x1. To unwedge the system, unplug and replug the fibre channel connec-
tion, or otherwise cause a LIP (Loop Initialization Primitive sequence) -
this will kick the firmware into getting unstuck.
NetBSD 9.99 June 24, 2009 NetBSD 9.99