genfs_can_access_acl_posix1e(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
GENFS_CAN_ACCESS_AC... NetBSD Kernel Developer's Manual GENFS_CAN_ACCESS_AC...


NAME
genfs_can_access_acl_posix1e -- generate a POSIX.1e ACL access control decision using vnode parameters
SYNOPSIS
#include <miscfs/genfs/genfs.h> int genfs_can_access_acl_posix1e(struct vnode *vp, kauth_cred_t cred, uid_t file_uid, gid_t file_gid, mode_t file_mode, struct acl *acl, accmode_t accmode);
DESCRIPTION
This call implements the logic for the UNIX discretionary file security model with POSIX.1e ACL extensions. It accepts the vnode vp, requesting credential cred, owning UID file_uid, owning GID file_gid, file permis- sions file_mode, access ACL for the file acl, and desired access mode accmode. This call is intended to support implementations of VOP_ACCESS(9), which will use their own access methods to retrieve the vnode properties, and then invoke genfs_can_access_acl_posix1e() in order to perform the actual check. Implementations of VOP_ACCESS(9) may choose to implement addi- tional security mechanisms whose results will be composed with the return value. The algorithm used by genfs_can_access_acl_posix1e() is based on the POSIX.1e ACL evaluation algorithm. The algorithm selects a matching entry from the access ACL, which may then be composed with an available ACL mask entry, providing UNIX security compatibility. Once appropriate protections are selected for the current credential, the requested access mode, in combination with the vnode type, will be com- pared with the discretionary rights available for the credential. If the rights granted by discretionary protections are insufficient, then super- user privilege, if available for the credential, will also be considered.
RETURN VALUES
genfs_can_access_acl_posix1e() will return 0 on success, or a non-zero error value on failure.
ERRORS
[EACCES] Permission denied. An attempt was made to access a file in a way forbidden by its file access permis- sions. [EPERM] Operation not permitted. An attempt was made to per- form an operation limited to processes with appropri- ate privileges or to the owner of a file or other resource.
SEE ALSO
genfs_can_access(9), vnode(9), VOP_ACCESS(9)
AUTHORS
This manual page and the current implementation of genfs_can_access_acl_posix1e() were written by Robert Watson.
BUGS
This manual page should include a full description of the POSIX.1e ACL evaluation algorithm, or cross reference another page that does. NetBSD 10.99 January 17, 2022 NetBSD 10.99
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.