- NetBSD Manual Pages
RPC.BOOTPARAMD(8) NetBSD System Manager's Manual RPC.BOOTPARAMD(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
bootparamd, rpc.bootparamd -- boot parameter server
bootparamd [-ds] [-i interface] [-r router] [-f file]
bootparamd is a server process that provides information to diskless
clients necessary for booting. It consults the file ``/etc/bootparams''.
It should normally be started from ``/etc/rc''.
This version will allow the use of aliases on the hostname in the
``/etc/bootparams'' file. The hostname returned in response to the boot-
ing client's whoami request will be the name that appears in the config
file, not the canonical name. In this way you can keep the answer short
enough so that machines that cannot handle long hostnames won't fail dur-
While parsing, if a line containing just ``+'' is found, and the YP sub-
system is active, the YP map bootparams will be searched immediately.
-d Display the debugging information. The daemon does not fork in
Specify the interface to become the default router. bootparamd
picks the first IPv4 address it finds on the system by default.
With -i, you can control which interface to be used to obtain the
default router address. -r overrides -i.
-s Log the debugging information with syslog(3).
-r Set the default router (a hostname or IP-address). This defaults
to the machine running the server.
-f Specify the file to use as boot parameter file instead of
/etc/bootparams default configuration file
Originally written by Klas Heggemann <firstname.lastname@example.org>.
You may find the syslog messages too verbose.
It's not clear if the non-canonical hack mentioned above is a good idea.
NetBSD 9.99 January 8, 1994 NetBSD 9.99