- NetBSD Manual Pages
INTIO(4) NetBSD/x68k Kernel Interfaces Manual INTIO(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intio -- X68K internal I/O space driver
intio0 at mainbus0
intio is a virtual device corresponding to the x68k internal I/O space.
Internal I/O space spans from 0xc00000 to 0xffffff of the x68k physical
address space, and is mapped permanently in the kernel virtual space at
the very early time of the kernel startup procedure.
intio driver manages the internal I/O space of x68k.
· Address range management to avoid confliction of address space
of which devices probe by touching hardware port is difficult.
· Interrupt vector management.
· bus_space(9) and bus_dma(9) implementation.
· Other utility functions.
intio is always required to run the NetBSD kernel.
x68k/intro(4), bus_dma(9), bus_space(9)
NetBSD 9.99 February 17, 2017 NetBSD 9.99