- NetBSD Manual Pages
VIO9P(4) NetBSD Kernel Interfaces Manual VIO9P(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vio9p -- VirtIO 9p front-end driver
vio9p* at virtio?
In conjunction with mount_9p(8), the vio9p driver enables a NetBSD system
running as a VM guest to mount an exported file system by the host via
virtio-9p. It exports a 9p end-point of virtio-9p via a character device
file for mount_9p(8).
Each exported file system is assigned a character device and accesible
via /dev/vio9p0, /dev/vio9p1 and so on, respectively, in exporting order
by the host.
The following command mounts the first exported file system by the host
# mount_9p -cu /dev/vio9p0 /mnt/9p
The vio9p driver first appeared in NetBSD 10.0.
The vio9p driver was written by Ryota Ozaki <firstname.lastname@example.org>.
NetBSD 9.99 October 24, 2019 NetBSD 9.99