- NetBSD Manual Pages
UT(4) NetBSD/vax Kernel Interfaces Manual UT(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ut -- UNIBUS TU45 tri-density tape drive interface
ut0 at uba0 csr 0172440 vector utintr
tj0 at ut0 drive 0
NOTE: This driver has not been ported from 4.4BSD yet.
The ut interface provides access to a standard tape drive interface as
describe in vax/mtio(4). Hardware implementing this on the VAX is typi-
fied by the System Industries SI 9700 tape subsystem. Tapes may be read
or written at 800, 1600, and 6250 BPI.
tj%d: no write ring. An attempt was made to write on the tape drive when
no write ring was present; this message is written on the terminal of the
user who tried to access the tape.
tj%d: not online. An attempt was made to access the tape while it was
offline; this message is written on the terminal of the user who tried to
access the tape.
tj%d: can't change density in mid-tape. An attempt was made to write on
a tape at a different density than is already recorded on the tape. This
message is written on the terminal of the user who tried to switch the
ut%d: soft error bn%d cs1=%b er=%b cs2=%b ds=%b. The formatter indicated
a corrected error at a density other than 800bpi. The data transferred
is assumed to be correct.
ut%d: hard error bn%d cs1=%b er=%b cs2=%b ds=%b. A tape error occurred
bn. Any error is fatal on non-raw tape; when possible the driver will
have retried the operation which failed several times before reporting
tj%d: lost interrupt. A tape operation did not complete within a reason-
able time, most likely because the tape was taken off-line during rewind
or lost vacuum. The controller should, but does not, give an interrupt
in these cases. The device will be made available again after this mes-
sage, but any current open reference to the device will return an error
as the operation in progress aborts.
The ut driver appeared in 4.2BSD.
May hang if a physical error (non-data) occurs.
NetBSD 10.99 February 17, 2017 NetBSD 10.99