- NetBSD Manual Pages
UTHUM(4) NetBSD Kernel Interfaces Manual UTHUM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
uthum -- TEMPer and TEMPerHUM USB temperature and humidity sensor
uthum* at uhidev? reportid ?
The uthum driver provides support for the pcsensors TEMPer and TEMPerHUM
HID device. The sensor possesses a collection of sensor values which are
made available through the envstat(8) interface. The humidity data unit
is ``%RH'' and the temperature data unit is ``degC''.
intro(4), uhidev(4), envstat(8)
The uthum driver was originally written by Yojiro UO <firstname.lastname@example.org>.
NetBSD porting was done by Antoine Reilles <tonio@NetBSD.org>.
The TEMPer and TEMperHUM have various versions which have the same
VID/PID and they need different data processing. Currently only two
types are supported.
NetBSD 10.99 November 23, 2009 NetBSD 10.99